Skip to Content
avatar image
Former Member

MDM Syndication Server Config

Hi All,

I have configured the syndication server as to achieve automated syndication but it does not seem to run. Ready folder always empty and so is archive folder and the report log shows no action from the syndication server. I have created a syndication map that looks for any newly created records and syndicates them out, and I would like to automate this process.

To achieve automated syndication I have done the following:

1. Created a new remote system

2. Created an outbound port and assigned the syndication map and tied it to the above remote system

3. configured the mdss.ini file as follow:

[GLOBAL]

MDM Server Name=XXXXXXXXX

Auto Syndication Task Enabled=True

Auto Syndication Task Delay (seconds)=0

Default Interface Language Code=eng

Default Interface Country Code=US

String Resource Dir=C:\Program Files\SAP MDM 5.5\Syndication Server\LangStrings\

Log Dir=C:\PROGRA1\SAPMDM1.5\SYNDIC~2\Logs

SLD Registration=False

[RepositoryXXXXXXXXX:MAXDB1MXDB_6_16_4_3]

User=Admin

Password=

I have my doubts about the ini file but you guys be the judge.

Under the Syndication Server folder i get the following error: Auto syndication failed connecting to MDM Server: XXXXXXXXX

Thanks in advance,

Ginobili

Edited by: Faissal Chafouk on Feb 4, 2009 9:54 PM

Edited by: Faissal Chafouk on Feb 4, 2009 10:31 PM

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Feb 05, 2009 at 03:21 AM

    Hi,

    Please see whether you have opened the ports 20003, 20007 & 20010 which are used by Syndication

    server.

    Hope this helps.

    Regards,

    Pramod

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Please ask your Basis or Network guys, they will be able to tell you

      whether these ports are opened or not.

      Regards,

      Pramod

  • avatar image
    Former Member
    Feb 05, 2009 at 03:43 AM

    Hi,

    Check the following:

    1. Check whether Syndication Server and MDM Server are of same version.

    2. Pass the MDM Server IP Address in MDSS.ini file for the entry MDM Server Name.

    3. If the Admin user has password associated with it then same is to specified in MDSS.ini file under your repository section against the property PasswordE. For this, remove the E from the property PasswordE , enter the Admin password and restart the Syndication Server.

    Regards,

    Jitesh Talreja

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      It is mandatory that both MDM Server and Syndication Server should be of same version. Also you dont need to enter the repository details manually it should be done automatically. In your case MDM server and Syndication server are not able to communicate hence this thing is not happening automatically.

      Regards,

      Jitesh Talreja

  • avatar image
    Former Member
    Feb 05, 2009 at 04:59 AM

    Thanks for the replies, but I am still getting the same error: Auto syndication failed connecting to MDM Server: XXXXXXXXX

    Pramod, how to check which ports were opened?

    Jitesh:

    1. Check whether Syndication Server and MDM Server are of same version.

    I checked all the servers and they are all of the same version

    2. Pass the MDM Server IP Address in MDSS.ini file for the entry MDM Server Name.

    Where do I add the IP address should it look somthing like this:

    MDM Server Name=XXXXXXXXX192.168.0.65

    3. If the Admin user has password associated with it then same is to specified in MDSS.ini file under your repository section against the property PasswordE. For this, remove the E from the property PasswordE , enter the Admin password and restart the Syndication Server.

    I have added the server password, I am not sure what is PasswordE could you please reiterate...

    Thanks in advance for your help...

    G..

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 05, 2009 at 05:11 AM

    Hi Faissal,

    Check out for the following:

    - Create a New user for accessing the MDM repository.and give it the Admin control by assigning that user to the Admin role.

    eg: Create a User say XYZ in MDM console and assign the Admin role to this user and Give a Unique password to this user.

    - Now in your MDSS.ini file you should be able to view your Repository name that you have careted in Console.Under this rep mention the username and Password as the one you have just created ie XYZ and PWD.The reason being may be keeping the password as blank could be a possible reason for teh automatic syndication not happening.

    - Also after making changes in the Syndication server restart the syndication and MDM server form your service.msc in Run command.

    - Also reduce the time of syndication in your mdss.ini file to 10 sec for monitoring of teh syndication.

    You can slo refer the below link for futher assisstance:

    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/8973bcaf-0801-0010-b7a7-f6af6b1df00e(mdm import and syndication server)

    http://help.sap.com/saphelp_mdm550/helpdata/en/93/e0cc3ac77c4319ad70ef1da0f969b9/content.htm

    Hope It Helped

    Thanks & Regards

    Simona Pinto

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Simona,

      When I first open mdss.ini file I don't see the repository name. I since have added it manually. Should it automatically pick up the rep name from mds.ini file? Since adding the rep name it stays there.

      In any case I am still unable to connect to the server (as see below) Do you think having the host name and the server be the same might be causing the problem?

      MDM Server Log v1.0

      Location: C:\PROGRA1\SAPMDM1.5\SYNDIC~2\ServerU090205081312.xml

      Opened: 15:00:16 GMT, Thursday, February 05, 2009

      Host name: srv2k3mdm

      Process id: 5996

      Compile type: RELEASE_32

      hide

      Thread Timestamp Details

      2524 2009/02/05 15:00:16.423 GMT Starting auto syndication

      4508 2009/02/05 15:00:16.443 GMT Auto syndication failed connecting to MDM Server: srv2k3mdm

      Thanks for your mentoring...

      G...

  • avatar image
    Former Member
    Feb 05, 2009 at 05:35 AM

    Hi,

    Check the below Bold Paramaters

    MDM Server Name=10.200.12.50

    Auto Syndication Task Enabled=True

    Auto Syndication Task Delay (seconds)=50

    Default Interface Language Code=eng

    Default Interface Country Code=US

    String Resource Dir=C:\Program Files\SAP MDM 5.5\Syndication Server\LangStrings\

    Log Dir=C:\PROGRA1\SAPMDM1.5\SYNDIC~2\Logs

    SLD Registration=False

    RepositoryXXXXXXXXX:MAXDB1MXDB_6_16_4_3

    User=Admin

    Password=

    If you have password for Admin user then in MDSS.ini under your repository section you will get the Username and Password entry, just pass the Admin password for Password entry and restart the Syndication Server. But if the entry is PasswordE then remove the E and then give the Admin password.

    Also check the value of Auto Syndication Task Delay. Set it to 50 for time being. This is the time for which Syndication Server will take to process the file.

    Regards,

    Jitesh Talreja

    Add comment
    10|10000 characters needed characters exceeded