Skip to Content
avatar image
Former Member

re-install jdk in the server

Hi ,

Right now my server is running on jdk1.4

Could any one please direct me how to switch it to jdk1.5?

Regards,

Krish

Edited by: Krish Krish on Feb 4, 2009 1:32 PM

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 05, 2009 at 12:43 PM

    Hi,

    Which version of WAS, EP, NWDS are you using? If you are using JDK 1.5 for ur NWDS already, then you have to look for JDK version of server alone. Please check the compatible versions of Java for your current WAS and EP. If JDK 1.5 is supported, then you can install 1.5 also on same server without uninstalling 1.4 and change the JRE used by server by configuration with config tool in offline mode.

    Regards,

    Harini S

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 04, 2009 at 02:48 PM

    Hi,

    SAP WAS server should be compatible with the JDK before upgrading... Is this criterion met in your case?

    Regards

    Ayyapparaj

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 05, 2009 at 12:24 PM

    Hi Krish,

    Both NWDS & WAS should be of the same release version. Though it may work if they are from different SPs versions for the same release.

    As you say your application needs jdk 1.5, it seems you developed it with NWDS 7.1 release and your WAS is from NW 7.0 release which requires jdk 1.4. This will not work as they belong to different releases. You will need to uninstall WAS & install the compatible version.

    Hope I clarify your query.

    Kind Regards,

    Nitin

    Add comment
    10|10000 characters needed characters exceeded