Skip to Content
avatar image
Former Member

SAP PI Sender Mail Adapter - Message not identified as new message

Hi,

I have configured a scenario where mail folder is polled hourly with imap4 for new mails.

There is no additional filter as only relevant mails are forwarded to the definied folder and the mails are deleted by the channel once processed. Attached you will find a screenshot of the configured channel.cc-sender-mail.png

Occasionally we have the problem, that the channel does not recognize the mails as new mail:

0 new messages found among 1 messages in total
0 actions[s] taken

Can you tell me, where we need to change the configuration in order to have all mails processed properly?

Thanks and regards,

Lisa

cc-sender-mail.png (48.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 09, 2016 at 08:57 AM

    Hello Lisa,

    Check if the below link helps

    https://archive.sap.com/discussions/thread/1856734

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Raghuraman,

      thanks für the link. Unfortunately the provided information don't give a solution.

      The note 856599 - FAQ: XI 3.0 / PI 7.0 / PI 7.1 Mail Adapter (Other Sender related Questions > Q: My mail messages are not picked up.) states, that all unread messages are picked up using IMAP. However, looking at the message from the mail client point of view, it is still marked as "unread". The issue seems to be, that the channel does not recognize this.

      An error does not occur.

      Regards

      Lisa