Skip to Content
0

Missing field content in a vendor fields when downloaded to Excel from alv report.

Nov 09, 2016 at 07:27 AM

31

avatar image
Former Member

Hi

I need Help I have a collapsing report that I created with

REUSE_ALV_GRID_DISPLAY I have sorted the alv with Lifnr and Vendor name It works perfectly but issue starts when I download it to Excel the Vendor name is missing in the collapsed mode of Excel but when you drill down its there.They want to see it before they even stretch it.Or If you can help me display the subtotals and grandtotal only maybe it will sove the problem.

Note: I download to excel with standard toolbar List-Export-Spreadsheet.

My sort.

wa_sort-fieldname = 'LIFNR' .
wa_sort-up = 'X'.
APPEND wa_sort TO gt_sort.

wa_sort-fieldname = 'NAME' .
wa_sort-up = 'X'.
Wa_SORT-EXPA = 'X'.
wa_sort-subtot = 'X'.
wa_sort-tabname = 'ITAB'.
APPEND wa_sort TO gt_sort

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

avatar image
Former Member Nov 09, 2016 at 07:29 AM
0
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 09, 2016 at 07:29 AM
0
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 09, 2016 at 07:30 AM
0

Provided the screenshot difference above for report and excel.My mistake vendor account number not pulling through the Excel sheet.

Share
10 |10000 characters needed characters left characters exceeded