Skip to Content
author's profile photo Former Member
Former Member

Unable to login into Portal with J2ee_admin

Hi all,

We are using a portal system ( dual stack) but the portal is pointing to different instance(ABAP, R/3 as backend ) running in the same box. Recently i have tried with user mapping , unknowingly i have changed some settings in config tool. After the restart of the instance, none of the users unable to login into portal.

Even for J2ee_admin ( user authenticationfailed) in portal. But i am able to login with the same J2ee_admin password in visual adminstrator.

Can anyone tell me, what could be the reason for this issue?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2009 at 08:21 AM

    HI

    Please follow the below given steps

    STEP-1: Enable "SAP*"

    1.Start the Config Tool C:\usr\sap\<SID>\<engine-instance>\j2ee\configtool\configtool.bat

    Ex: D:\usr\sap\F02\JC00\j2ee\configtool --> configtool.bat

    2.Goto cluster-data --> Global server configuration --> services --> com.sap.security.core.ume.service

    3.Double-click on the property "ume.superadmin.activated = TRUE"

    4.Double-click on the property "ume.superadmin.password=<Enter any password ex: abc123>"

    5.Save.

    6.Restart the engine.

    STEP-2: Login with "SAP*" into portal

    1. http://<host>:<Port>/useradmin/index.jsp

    2. Enter userid / password as" SAP* / <password ex: abc123>"

    3. Search for "Administrator" user

    4. Reset or change password for "Administrtor"

    STEP-3: Disable "SAP*"

    1.Start the Config Tool C:\usr\sap\<SID>\<engine-instance>\j2ee\configtool\configtool.bat

    Ex: D:\usr\sap\F02\JC00\j2ee\configtool --> configtool.bat

    2.Goto cluster-data --> Global server configuration --> services --> com.sap.security.core.ume.service

    3.Double-click on the property "ume.superadmin.activated = FALSE"

    4.Save.

    5. Restart the engine.

    STEP-4: Login with "Administrator"

    1. http://<host>:<Port>/useradmin/index.jsp

    2. Enter userid / Password as "Administrator / <password>

    3. it will ask change password just change it.

    Note: Just increase the no.of invalid_attemps during the deployment then make it according to your standereds.

    1.Start the Config Tool C:\usr\sap\<SID>\<engine-instance>\j2ee\configtool\configtool.bat

    Ex: D:\usr\sap\F02\JC00\j2ee\configtool --> configtool.bat

    2.Goto cluster-data --> Global server configuration --> services --> com.sap.security.core.ume.service

    ume.logon.security_policy.lock_after_invalid_attempts = <number ex: 4>

    3. Save & restart.

    Thanks and regards

    Revanth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2009 at 07:09 PM

    I am confused. You say it is a dual stack system, but you say that you're trying j2ee_admin, which is for single stack Java.

    Anyway, in the config tool, when looking at the UME settings, look for anything with the "changed" flag and just make sure they look OK. Feel free to post them here...

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2009 at 06:35 AM

    Dear Raja,

    Please ensure that you have the ticketkeystore set in the visual administrator.

    Logon to visual admin-under server-services scroll down to keystorage and under runtime check if your TicketKeystore exists.

    If it does, check for the expiry and if it does not, create one there.

    Good Luck!

    Sandeep

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2009 at 11:01 AM

    Dear All,

    I have checked the Key certificate, its valid. I have activated SAP* as rev suggested. But SAP* itslef is not able to login. I dont think it's user authentication problem. something wrong with UME settings.

    Is there any user mapping settings in config tool? or any other suggestion. It will be greatful to you all.

    Thanks

    Raj

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.