Skip to Content
avatar image
Former Member

Buyer Account, Welcome mail with password & LDAP related query

Hi All

We are facing an issue with the LDAP configuration while creating Buy side users, please see below

If anyone of you could help, please provide your contact details or a solution to overcome this

Background

We have installed SAP E-Sourcing 5.1 On-premise.

We are currently doing the post installation configuration

- Imported the Out of the Box enterprise Deployment Workbook (We have not modified the contents of the workbook)

- We have configured an SMTP mail host to send and receive all mails from the application

Query

Based on the enterprise Deployment Workbook, the system has created the following Directory configuration settings pointing to different LDAP system

DISPLAY_NAME EXTERNAL_ID

QA SunOne 5.2 u2013 Buyside dir.qa.sun.bs

QA SunOne 5.2 u2013 Sellside dir.qa.sun.ss

QA ActiveDirectory 2003 - Buyside dir.qa.ms.bs

QA ActiveDirectory 2003 u2013 Sellside dir.qa.ms.ss

QA Oracle 9.0.2 u2013 Buyside dir.qa.ora.bs

QA Oracle 9.0.2 u2013 Sellside dir.qa.ora.ss

When we are creating the Buyside users (If we use the Check Box u2013 Create Directory account), we are getting a communication error

If we uncheck it, it creates the account but the system does not generate the welcome mail. We understand that the welcome mail has the system generated password to log-onto the application as the Buyer.

We are also not able to create the local users, as the password.properties template isnu2019t available in the downloaded software, we donu2019t know the format thatu2019s expected by the system.

Please let us know, if there is an alternate way to get the password even without using LDAP or Local directories.

Incase LDAP or creation of local directory is the key, then please let us know whatu2019s happening incorrectly in our case.

This has become a show stopper for us going any forward.

Request your help ASAP

Regards

Tridip

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    May 19, 2009 at 04:38 PM

    What did you do to resolve this?

    I think this is the issue I am facing.

    Thanks

    JS

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 26, 2009 at 06:21 PM

    I haven't seen this particular issue before. In past installations I have used the local buy / sell side directory and inactivated the others. On Driver config options under Authenticator Iu2019ve only check u201Cchangeable passwordsu201D, u201Cnew Accountsu201D and u201CBrowsingu201D.

    Also, Iu2019ve not used the system default mail config. Iu2019ve always cloned the default mail config and used a custom.

    Hope this provides help.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 26, 2009 at 07:15 PM

    Hi Tripathi,

    You should only have the directories you are using active. One Buyside and One Sellside. When you create a user it needs to be in the proper directory.

    LJ's suggestion that you should duplicate the Mail Confuguration and use that is correct. Either way look in the Mail Configuration and confirm your Account Activation emails are set to send. If they are set to send you can check the mail queues (Sent & Pending) to see if the mails are actually sending.

    FYI

    As I understand the password.properties file is only used for local directories. If you are using a LDAP the passwords and users are coming from the LDAP.

    Regards,

    James

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi All

      I had the same problem when I tried doing the email Set-up

      I finally realised that you need to do the configuration steps for SMTP using the enterprise user and the system user. If you have done this setting as only the system user the mails will be in Awaiting retry.

      Do this and the mails will start flowing, incase your SMTP mail server is working fine

      Please do the following settings logged in as System User and Enterprise User

      System Properties->searrch for messaging

      Set - Property - Value - Context

      messaging messaging.smtp.mailhost replace the default with your value System Context

      messaging messaging.smtp.port 25 System Context

      Also please let me know what is the status of the messages in your Queued Messages

      This should work

      Do let me know, if it does

      Regards

      Tridip

      Edited by: Tridip Chakraborthy on May 27, 2009 11:57 AM

      Edited by: Tridip Chakraborthy on May 27, 2009 12:02 PM

      Edited by: Tridip Chakraborthy on May 27, 2009 12:02 PM