Skip to Content
0
Former Member
Jan 29, 2009 at 02:32 PM

BO XI 3.0 Windows AD authentication with Java Infoview

23 Views

Hi All,

I have been searching through the forums to see if I can find a resolution to my problem with no luck.

I am trying to set up the Java Infoview windows active directory authentication, with a view to going to full SSO using vintela.

I have been following Business Object Enterprise XI 3.0 Java Info View - Active Directory SSO with Vintela guide and everything is fine until the configuring Kerberos for Java application. At this point I can log into Deski / Rich Client using Windows AD, but when I try to log into Java Infoview the following error is displayed:

'Account Information Not Recognized: The Active Directory Authentication plugin could not authenticate at this time. Please try again. If the problem persists, please contact your technical support department. (FWM 00005) '

On testing the kinit, the message 'New ticket is stored in cache file...' is displayed.

In the error logs I can find the following errors:

jce_default.log

<log4j:event logger="com.crystaldecisions.sdk.plugin.authentication.ldap.internal.SecWinADAction" timestamp="1233231880107" level="ERROR" thread="http-8080-Processor23">

<log4j:message><![CDATA[LoginContext failed. No valid credentials provided (Mechanism level: Fail to create credential. (63) - No service creds)]]></log4j:message>

</log4j:event>

stdout.log :

Debug is true storeKey false useTicketCache false useKeyTab false doNotPrompt false ticketCache is null isInitiator true KeyTab is null refreshKrb5Config is false principal is null tryFirstPass is false useFirstPass is false storePass is false clearPass is false

[Krb5LoginModule] user entered username: michaelm

Acquire TGT using AS Exchange

principal is michaelm

EncryptionKey: keyType=3 keyBytes (hex dump)=0000: FD 16 9E D9 2A 3D 7F 16

EncryptionKey: keyType=1 keyBytes (hex dump)=0000: FD 16 9E D9 2A 3D 7F 16

EncryptionKey: keyType=23 keyBytes (hex dump)=0000: 76 6B 62 D3 DB 02 3F 90 44 34 69 D8 63 93 CA 66 vkb...?.D4i.c..f

EncryptionKey: keyType=16 keyBytes (hex dump)=0000: 43 67 BF 8A 46 DC 5D AB 3D 4C DF CE 2C 67 83 D9 Cg..F.].=L..,g..

0010: D0 32 43 97 5E 0D 9B 6E

EncryptionKey: keyType=17 keyBytes (hex dump)=0000: 9D 47 FF 40 2D ED F7 28 5C 1A E6 3C 12 C5 CB 3B .G.@-..(\..<...;

Commit Succeeded

The krb5.ini file is as follows:

krb5.ini - (note have tried the longer version with the libdefaults and retuns the same error)

[realms]

TEST.INTERNAL = {

kdc = ARWEN.test.internal

bscLogin.conf

com.businessobjects.security.jgss.initiate {

com.sun.security.auth.module.Krb5LoginModule required debug=true;

};

Thanks in advance

Mike