Skip to Content
avatar image
Former Member

Problem with JDBC adapter while configuring with Sybase database

Hi all,

Here I am facing some problem with JDBC adpater while configuring the scenario that is while

connecting to the SYBASE database.

Here is the error which I am facing,

Error during database connection to the database

URL 'jbdc:sybase:Tds:IP:Port/database' using the JDBC

driver 'com.sybase.jdbc2.tds.Tds': 'com.sap.aii.adapter.jdbc.sql.DriverM

anagerException: Cannot establish connection to

URL 'jbdc:sybase:Tds:IP:Port/database': java.lang.ClassCastException'

We can use this JDBC driver in an EP 7.0 through the JDBC Connector

service in the Visual Admin using JDBC 1.X protocol but we don't

achieve use it with the JDBC 2.0 protocol. In order to connect with

JDBC 2.0 protocol we set the next configuration:

Object Factory: com.sybase.jdbc2.jdbc.SybObjectFactory

DataSourceType: ConnectionPoolDataSource

*CPDS Classname: com.sybase.jdbc2.jdbc.SybConnectionPoolDataSource

Also in the JDBC Connector service in the XI 3.0 Visual Admin we can't

use the driver with JDBC 1.X protocol nor JDBC 2.0"

Please help us in solving this issue.

Is it possible to connect to SYBASE database using XI 3.0 and PI 7.0?

Thanks,

Soorya

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • May 12, 2009 at 10:24 PM

    Hello,

    Yes, it's possible.

    Sybase provides the JDBC Driver as you can see from the link below:

    http://www.aquafold.com/docs-jdbcdrivers-sybase-ase.html

    So you just need to ask for the driver from Sybase company and then deploy it.

    Check if you have the jdbc driver 'com.sybase.jdbc2.jdbc.SybDriver' correct specified in the communication channel.

    BR,

    Franklin

    Add comment
    10|10000 characters needed characters exceeded