Skip to Content
0
Former Member
Jan 27, 2009 at 05:55 PM

Crystal Reports 2008 Runtime with Visual Studio 2008

103 Views

I'm trying to deploy an application that shows a single report. I've tried installing the Crystal Reports 2008 runtime using the MSI and also from a Merge Module I found. In both instances, it's not working. I get to the spot where it asks for the Product ID. I've tried putting in the registration code, the keycode from VS2008's About page, and the same keycode without dashes. None of the codes will take. So, I've left it blank. After the very long (5 minute) install process, the .rpt files are not recognized; meaning, they don't just open. If I build the .rpt file into the win app and use the built-in viewer, I get an error saying that it can't find the CrystalDecisions.Windows.Forms (v 10.5.*) assembly. However, there are multiple versions (9.1.5000, 11.0.3300, 12.0.1100, and 12.0.2000) of this installed in the GAC.

What's the issue? It shouldn't be this difficult to deploy CR. Simply ridiculous.