Skip to Content

Instance Based Access Control Bug?

Hello,

I tried to implement Instance Based Access Control following this guide. This worked well but the problem is that I cannot choose the Access Contexts because they are dependent on the BO I'm using. So I was using this code.

element Employee:EmployeeID;
[RelevantForAccessControl] association toEmployee to Employee;

However, there is a chapter in the Studio Documentation (7.2.2.2 Access Control Context) which says that you are able to use "Employee" and "Employee or Territory" access context which is exactly what I need.

I use this code:

[AccessControlContext(Employee)] element EmployeeUUID :UUID;

I made a business role in which I put the work center in. For my user, it works fine. But if I try it with any other user it does not work. I think it has something to do with the fact that it does not find the right permission.

Business Role:

User 1 (Working):

User 2 (Not working):

If anyone has an idea on how to fix this issue I would apprechiate it.

Best Regards,

Nathanael

pic1.png (82.9 kB)
pic2.png (103.1 kB)
pic3.png (97.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jun 13, 2018 at 04:13 AM

    Dear Nathanael Mangold

    Could you please create an incident for this issue? As we need to analyze this issue using our backend system.

    Regards
    Anant

    Add comment
    10|10000 characters needed characters exceeded

    • The issue had to do with the fact that the org unit was not available for access control. If you want to use an org unit for access control it needs to have at least one "function" assigned to it.