Skip to Content
0

HANA Express on Azure

Nov 08, 2016 at 06:53 PM

317

avatar image

Hi,

I created a CAL instance for HANA express on Azure. I made the following entry in my host file,

vhcalhxedb xx.xx(external IP)

The problem is, I am not able to log into https://xx.xx:53075 using any of the users(XSA_DEV, XSA_SHINE) mentions in the getting started document. I tried the different passwords and also the password used during instance creation. I keep getting the 'wrong credentials' error.

Also, using eclipse to connect to the instance using SYSTEM results in a IP not found error.

If anyone's come across this problem, please assist.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Benedict Venmani Felix Nov 09, 2016 at 06:12 PM
0

I created a new instance in AWS and logged in as SYSTEM and changed the password for XSA_DEV and XSA_SHINE. Now I am able to log-in with XSA_DEV, but shine user still gets 'permission denied'. I am not sure what privileges it lacks.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Could you provide more details on the current "permission denied" issue? Are you trying to use the XSA_SHINE user to log into the same XSA application as the original post?

The first error you hit with "wrong credentials" is a known issue in earlier versions that may be resolved by changing the password, as you've tried. Please also provide the following output, if possible, so we may verify if it is related:

SELECT * FROM SYS.USERS WHERE USER_NAME='XSA_SHINE'

0
Benedict Venmani Felix Nov 15, 2016 at 06:11 AM
0

Hello Mary,

Thank you for looking into this issue.

This is what I see when I login with XSA_SHINE,

Here's the select result from user - user.txt

Apart from PUBLIC and self schema, it has user paremeters, XS_RC_XS_AUTHORIZATION_ADMIN and XS_RC_XS_CONTROLLER_USER


xsa-shine.png (24.9 kB)
user.txt (1.7 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thank you for providing additional information on the XSA_SHINE user.

I've confirmed that the XSA_DEV user should have the correct privileges to log into WebIDE (port 53075). The XSA_SHINE user has access to the SHINE applications themselves, but not the WebIDE. It appears that this is expected behavior. I apologize for the confusion!

1

Thank you Mary for you help on this. I have linked this thread in the open SAP discussion, since other users had similar issues. Hope others find this useful.

0
Denys van Kempen
Nov 20, 2016 at 11:09 AM
0

Hi Benedict,

FYI

There is a video on the SAP HANA express playlist on the SAP HANA Academy YouTube Channel that addresses some of the issues you mention: https://youtu.be/iYOlVnew-to

Full playlist: bit.ly/2dZS2Fv

Regards,

Denys

Share
10 |10000 characters needed characters left characters exceeded