Skip to Content
author's profile photo Former Member
Former Member

Creating a new class type in the classification system

We are wanting to classify objects in a ZTABLE. We have a home grown system for defining our customer requirements that is used as the way for the sales people to communicate to the engineering dept. what the customer wants. A new need has come up that seems to be a good fit to be able to classify our customer requirements. I have been trying to create a new class type that is linked to our ZTABLE. However, even though it looks like we should be able to do this I have not been able to do it. I ran across some documentation that seems to imply that adding a new class type used to be possible, but no longer is.

Can anyone verify that creating a new class type is still possible to do? We are on ECC 5.0.

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2009 at 03:11 PM

    I have been searching SDN for the answer to this question for 2 days now, and cannot find a definitive answer.

    I have been able to create a new class object key for my ztable using SPRO, but I cannot seem to get the system to save my new class type I try to create after that.

    Where would I go to help as to how to do this? Have I posted this in the wrong forum? If so which forum should I post it in?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member


      Ok, thanks for that info. I did all this experimenting in a system that was scheduled to be overwritten, so I have another chance to do it better when I set it up for real. I am sure I will do as you suggest.

      However, an access key is still going to be required for FG CBCM to add the new subscreens is it not? I suppose you could create you own FG for the OBJECT_CHECK_ZTABLE FM, but it would fall outside the customer naming standard of not beginning with a "Z".

      BTW: Welcome to the SDN forums. I see this is your 1st post. There is an absolute wealth of info here. A simple search on SDN can sometimes make you look like a genius to your coworkers 😊

      Edited by: Larry Browning on Jun 22, 2009 1:12 PM

  • author's profile photo Former Member
    Former Member
    Posted on May 01, 2009 at 07:10 PM

    Can someone point me in the right direction as to how to create my own Class Type. Is there some documentation as to how to dow this? Other than what is fould in SPRO I have tried and tried but no joy for me.

    This is what I have done so far:

    in SPRO:

    1) Created an Object Key for my table ZLO_CUSTREQ. This table has a primary key of CRQNR (custormer requirements number which is I created) The documentation says that I need to add this key field to structure RMCLY (I did that). BUT, it also says the RMCLY is embeded in structure RMCLX and it is not. Do I need to modify RMCLX to add RMCLY as an append structure?

    2) Went to Maintain Object types and Class types and selected my table. Double clicked on Class Types in the Dialog Structure tree, which displayed an empty list of class types.

    I then Clicked New Entries button and filled in the fields: Class type(Z10), Description(Customer Requirements), Table(ZLO_CUSTREQ). in the Screens group I selected Keywords and Characteristics. In the Functions group I selected: Standard class type and Multiple classifications. I then Clicked the back arrow. This returned me to the Class Types list which now displayed my new class type.

    When I click the save button it kicks me out the the SPRO menu screen and I get the warning message "Class type Z10 does not have the classification status incomplete system" .

    Then, it won't let me re-enter the Maintain Object types and Class Types screen due to an error "View cluster is already open, go back with F3"

    When I hit F3 I am returned to the main SPRO screen. After navigating back to the Maintain Object types and Class types I continue to get the View cluster already open error. The only way I can get back to Maintain Object types and Class types is to completely exit SPRO and start over. When I do, class type Z10 is gone.

    I have repeated this procedure several times with always the same results.

    Can anyone please help me?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Ok, finally some joy!

      In step 2 I discovered that if I selected my table and another table that already had a class type defined, when I dbl clicked on class type, it would display the class types for the other table. I could then copy the type to my new type, make my changes and then save it. This worked. Happy dance!!!!!

      I have now been able to create my user defined screens for transactions CL20N, CL24, etc..

      My next step will be to create the OBJECT_CHECK_ZLO_CUSTREQ function module. So I guess I have answered my own question. Can I give myself points?

      I will leave this thread open until I get this thing working for sure.