Skip to Content
author's profile photo
Former Member

ESS - Travel and Expenses - Overview subarea dissapears!!!

Hi experts,

We implement the Travel and Expenses with the ESS. At first time, we have 3 "zones" in the Portal, overview, create new and personal information. But suddenly, the overview "zone" disappears. We don´t change anything in portal content nor in SPRO. We check the content of the SPRO and it looks fine for us. I put the content of the SPRO to you to see if there is something wrong.

Content of SPRO --> Personnel Management --> Employee Self-Service --> General Settings --> Home page for Self-Services:

- Define Resources:

EMPLOYEE_TRAVEL_ALLMYTRIPS_SRV----

-


>Travel & Expense: Trips and Expenses

EMPLOYEE_TRAVEL_CANCELTRIP_SRV----

-


>Travel & Expense: Cancel Trip

EMPLOYEE_TRAVEL_CCIMPORT_SRV----

-


>Travel & Expense: Credit Card Receipts

EMPLOYEE_TRAVEL_CHANGE_PERSNO_SRV----

-


>Travel & Expense: Switch to other Personnel number

EMPLOYEE_TRAVEL_EXPENSES_DELETE_SRV----

-


>Travel & Expense: Delete Expense Report Service

EMPLOYEE_TRAVEL_EXPENSES_SRV----

-


>Travel & Expense: Travel Expense Report Service

EMPLOYEE_TRAVEL_MYALERTS_SRV----

-


>Travel & Expense: My Alerts

EMPLOYEE_TRAVEL_PAG----

-


>Travel & Expense Page

EMPLOYEE_TRAVEL_PIC----

-


>Travel & Expense Picture

EMPLOYEE_TRAVEL_PLANNING_SRV

EMPLOYEE_TRAVEL_PROFILE_SRV----

-


>Travel & Expense: My Travel Profile

EMPLOYEE_TRAVEL_REQUEST_DELETE_SRV----

-


>Travel & Expense: Delete Trip Request Service

EMPLOYEE_TRAVEL_REQUEST_SRV----

-


>Travel & Expense: Travel Request Service

EMPLOYEE_TRAVEL_TRIPFORM_SRV----

-


>Travel & Expense: Travel Expense Form

-Define Areas:

EMPLOYEE_TRAVEL -

-


>Travel and Expenses

-Define Subareas

EMPLOYEE_TRAVEL_NEW----

-


>Create New

EMPLOYEE_TRAVEL_OVERVIEW -

-


>Overview

EMPLOYEE_TRAVEL_PERSINF----

-


>Personal Information

- Assign Subareas to Areas

EMPLOYEE_TRAVEL----


>EMPLOYEE_TRAVEL_NEW----

-


>2

EMPLOYEE_TRAVEL----


>EMPLOYEE_TRAVEL_OVERVIEW----

-


>1

EMPLOYEE_TRAVEL----


>EMPLOYEE_TRAVEL_PERSINF----

-


>3

-Define Services

EMPLOYEE_TRAVEL_ALLMYTRIPS -

-


>My Trips and Expenses

EMPLOYEE_TRAVEL_CANCELTRIP----

-


>Cancel Trip

EMPLOYEE_TRAVEL_CCIMPORT----

-


>My Credit Card Receipts

EMPLOYEE_TRAVEL_CHANGE_PERSNO----

-


>Switch Personnel Number

EMPLOYEE_TRAVEL_EXPENSEREPORT----

-


>Create Expense Report

EMPLOYEE_TRAVEL_EXPENSEREPORT_DELETE--->Delete Expense Report

EMPLOYEE_TRAVEL_MYALERTS----

-


>Mis alertas

EMPLOYEE_TRAVEL_MYPROFILE----

-


>My Travel Profile

EMPLOYEE_TRAVEL_PLANNING

EMPLOYEE_TRAVEL_REQUEST -

-


>Create Travel Request

EMPLOYEE_TRAVEL_REQUEST_DELETE----

-


>Delete Travel Request

EMPLOYEE_TRAVEL_TRIPFORM -

-


>Display Trip Form

-Assign Services to Subareas

EMPLOYEE_TRAVEL_NEW----


>EMPLOYEE_TRAVEL_EXPENSEREPORT---->30

EMPLOYEE_TRAVEL_NEW----


>EMPLOYEE_TRAVEL_PLANNING----

-


>20

EMPLOYEE_TRAVEL_NEW----


>EMPLOYEE_TRAVEL_REQUEST----

-


>10

EMPLOYEE_TRAVEL_OVERVIEW----


>EMPLOYEE_TRAVEL_ALLMYTRIPS----

-


>10

EMPLOYEE_TRAVEL_OVERVIEW----


>EMPLOYEE_TRAVEL_CCIMPORT----

-


>20

EMPLOYEE_TRAVEL_PERSINF----


>EMPLOYEE_TRAVEL_CHANGE_PERSNO---->20

EMPLOYEE_TRAVEL_PERSINF----


>EMPLOYEE_TRAVEL_MYPROFILE----

-


>10

Anyone please can help us?

Thanks in advance,

Manuel

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    author's profile photo
    Former Member
    Jan 22, 2009 at 09:44 AM
    Add comment
    10|10000 characters needed characters exceeded

  • Jan 22, 2009 at 09:50 AM

    Hi Manuel,

    I assume you are using the SAP ESS Business Package in the portal?

    Could you explain WHEN your problem occurs for your 'zone' (we call it an area / subarea group in xss homepage framework terms).

    Do other area's show up with the overview page? Do you see a portal page title being displayed?

    It's always hard to find the problem in XSS homepage framework, but we will manage 😊

    Cheers,

    Noël

    Hmmm after examining your detailed spro information I probably found it:

    Do you have a service called: EMPLOYEE_TRAVEL_OVERVIEW?

    That one is missing in your description.

    Edited by: Noël Hendrikx on Jan 22, 2009 10:51 AM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Noël,

      Yes we are using ESS on an EP 6.0 SPS 20 over an ECC 5.0.

      When we install it show the Overview Area and its subareas on Travel and Expenses tab.

      But after some weeks, yesterday, it suddenly disappears. The portal team don´t do any changes in portal content nor in SPRO. And the values in SPRO (in the first topic) are correct for us. So we don´t know what could happen, don´t know what to do....

      Thanks in advance,

      Manuel