Skip to Content
avatar image
Former Member

Encountered problem with Homogenous system copy...

Hi Team,

I have encountered a problem while performing system copy. Sourse system and target system is running on same kind of setup like OS ,database ,patches etc with different SID 's.

I have sucessfully Restored Offline Backup of Source System onto Target System and after restoration of offline backup and i have created a control file and altered it to use in target system with out any errors and placed in target system.

However,when i'm trying to open the data base in target system we are encountering the below message

alter database open

*

ERROR at line 1:

ORA-01113: file 1 needs media recovery

ORA-01110: data file 1: 'D:\ORACLE\HYD\SAPDATA1\SYSTEM_1\SYSTEM.DATA1'

SQL> alter database recover automatic using backup controlfile until cancel;

alter database recover automatic using backup controlfile until cancel

*

ERROR at line 1:

ORA-00279: change 3384907 generated at 01/07/2012 15:11:50 needed for thread 1

ORA-00289: suggestion : D:\ORACLE\HYD\ORAARCH\HYDARCHARC00001.001

ORA-00280: change 3384907 for thread 1 is in sequence #1

ORA-00278: log file 'D:\ORACLE\HYD\ORAARCH\HYDARCHARC00001.001' no longer

needed for this recovery

ORA-00308: cannot open archived log 'D:\ORACLE\HYD\ORAARCH\HYDARCHARC00001.001'

ORA-27041: unable to open file

OSD-04002: unable to open file

O/S-Error: (OS 2) The system cannot find the file specified.

Please note that both my SRC & TGT systems and runnig in archive mode and we have used the offline backup for system copy.

My system setup is :

OS: Windows 2003

Database : Oracle 9.2.0.4.0

SAP 4.7 EE

Seek your suggessions to fix this issue and kindly let me know if you need further information.

Thanks & Regards,

Vinod

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 21, 2009 at 02:35 PM

    Hi,

    > I have sucessfully Restored Offline Backup of

    The error clearly indicate that your offline backup procedure is not correct.

    The database was not properly closed when the backup was done and oracle it is indicating this inconsistency:

    > ORA-01113: file 1 needs media recovery

    > ORA-01110: data file 1: 'D:\ORACLE\HYD\SAPDATA1\SYSTEM_1\SYSTEM.DATA1'

    How do you perform offline backups?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 09, 2009 at 08:55 AM

    Hi Vinod,

    Why you are merging all the solutions, first you got only OPS$ user issue you corrected with note 400241. in this scenario you need to find the actual user with which one database is getting connected.

    Here you need to see the SAPUSER entries. In this table the user should be as your achema owner.

    just change the env vatiable accordingly.

    And last you have created as SAPSID which is not the exact one, thats why you are getting the error unable to find from V$INSTANCE. To avoid this error please drop SAPUSER table and recreate with entries user name SAPR3 and password as sap. Change your env variable of dbs_ora_schema as SAPR3, delete all old logs (dev_w*) retry.

    Regards

    Nick Loy

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Nick,

      Thanks for your response, Let me clear you about my system configuration.

      I'm using 4.7 EE and oracle 9.2.0.4, I believe for 4.7 EE schema user is SAP<SID> i suppose sapsr3 for ecc 6.0 ,Correct me if i'm wrong and i could see the same user available in SAPUSER table as a owner.

      so i have changed the password of schema user id "SAPHYD" to 'sap' and using SAPDBA since it is 4.7 EE version as per my scenario. However i'm getting the r3trans report :0012 as shown below

      SQL> select owner,tablespace_name from dba_tables where table_name='SAPUSER';

      OWNER TABLESPACE_NAME

      -


      -


      OPS$SAPKALAM\HYDADM SYSTEM

      Translog Error:

      *4 ETW000 [dbntab.c ,00000] *** ERROR => NTAB: SELECT VERSION/DBASE FROM DDNTT FAILED*

      4 ETW000

      405 6.832509

      Please correct me, If i'm wrong.

      Many Thanks,

      Vinod

  • avatar image
    Former Member
    Feb 10, 2009 at 05:09 AM

    Hi Vinod,

    According to your scenario, you are saying that user ids are correct and as well as schema owner.

    Can you do one thing, just delete all log files from work directory (dev_w*) and try to start sap application. and send us the log file dev_w0. In this file we can easily identiry the exact error.

    And you are getting the error NTAB/DD mismatch means have anybody changed and standard database settings means like charactersets etc? If not please make sure you are using correct kernel or not?

    Before send us the log file dev_w0.

    Regards

    Nick Loy

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Nick,

      Sorry for the delay in getting back you, i have done with all the things which you have suggested like cleared out all entires of DEV_W* in work directory and tried to start the instance but no luck, however getting the same error as shown below.

      I have not made any major changes at DB level like charachter set change etc and kernal release is 620.

      R3trans -d output point out some error as below:

      *4 ETW000 [dbntab.c ,00000] *** ERROR => NTAB: SELECT VERSION/DBASE FROM DDNTT FAILED*

      4 ETW000 379 6.832457

      Please see the attached DEV_W* trace which might helps to investigate further

      -


      trc file: "dev_w0", trc level: 1, release: "620"

      -


      *

      • ACTIVE TRACE LEVEL 1

      • ACTIVE TRACE COMPONENTS all, M

      *

      B

      B Sat Feb 11 14:46:36 2012

      B create_con (con_name=R/3)

      B Loading DB library 'D:\usr\sap\HYD\SYS\exe\run\dboraslib.dll' ...

      B Library 'D:\usr\sap\HYD\SYS\exe\run\dboraslib.dll' loaded

      B Version of 'D:\usr\sap\HYD\SYS\exe\run\dboraslib.dll' is "620.02", patchlevel (0.549)

      B New connection 0 created

      M systemid 560 (PC with Windows NT)

      M relno 6200

      M patchlevel 0

      M patchno 674

      M intno 20020600

      M pid 3020

      M

      M ***LOG Q0Q=> tskh_init, WPStart (Workproc 0 3020) [dpxxdisp.c 1028]

      I MtxInit: -2 0 0

      M DpShMCreate: sizeof(wp_adm) 11280 (752)

      M DpShMCreate: sizeof(tm_adm) 1690816 (8412)

      M DpShMCreate: sizeof(wp_ca_adm) 18000 (60)

      M DpShMCreate: sizeof(appc_ca_adm) 6000 (60)

      M DpShMCreate: sizeof(comm_adm) 192000 (384)

      M DpShMCreate: sizeof(wall_adm) (22440/34344/56/100)

      M DpShMCreate: SHM_DP_ADM_KEY (addr: 032F0040, size: 1976320)

      M DpShMCreate: allocated sys_adm at 032F0040

      M DpShMCreate: allocated wp_adm at 032F0560

      M DpShMCreate: allocated tm_adm_list at 032F3170

      M DpShMCreate: allocated tm_adm at 032F3198

      M DpShMCreate: allocated wp_ca_adm at 0348FE58

      M DpShMCreate: allocated appc_ca_adm at 034944A8

      M DpShMCreate: allocated comm_adm_list at 03495C18

      M DpShMCreate: allocated comm_adm at 03495C30

      M DpShMCreate: allocated ca_info at 034C4A30

      M DpShMCreate: allocated wall_adm at 034C4A38

      X EmInit: MmSetImplementation( 2 ).

      X <ES> client 0 initializing ....

      X

      X Sat Feb 11 14:46:37 2012

      X Using implementation std

      M <EsNT> Memory Reset enabled as NT default

      X ES initialized.

      M calling db_connect ...

      C Got ORACLE_HOME=D:\oracle\ora92 from environment

      C Client NLS settings: AMERICAN_AMERICA.WE8DEC

      C Logon as OPS$-user to get SAPHYD's password

      C Connecting as /@HYD on connection 0 ...

      C Attaching to DB Server HYD (con_hdl=0,svchp=06270FCC,svrhp=06273224)

      C

      C Sat Feb 11 14:46:50 2012

      C Starting user session (con_hdl=0,svchp=06270FCC,srvhp=06273224,usrhp=0627B9FC)

      C Now I'm connected to ORACLE

      C Got SAPHYD's password from table SAPUSER

      C Got SAPHYD's password from OPS$-user

      C Disconnecting from connection 0 ...

      C Closing user session (con_hdl=0,svchp=06270FCC,usrhp=0627B9FC)

      C Now I'm disconnected from ORACLE

      C Connecting as SAPHYD/<pwd>@HYD on connection 0 ...

      C Starting user session (con_hdl=0,svchp=06270FCC,srvhp=06273224,usrhp=0627B9FC)

      C Now I'm connected to ORACLE

      C Database NLS settings: AMERICAN_AMERICA.WE8DEC

      C Couldn't read V$INSTANCE: sqlcode=942

      C Couldn't get creation timestamp from V$DATABASE: sqlcode=942

      B Connection 0 opened

      B Wp Hdl ConName ConId ConState TX PRM RCT Date Time DBHost

      B 000 000 R/3 000000000 ACTIVE NO YES NO 20120211 144637

      B ***LOG BZA=> table SVERS does not exist on database [dblink#1 @ 1292] [dblink 1292 ]

      M ***LOG R19=> tskh_init, db_connect ( DB-Connect 004096) [thxxhead.c 1102]

      M in_ThErrHandle: 1

      M *** ERROR => tskh_init: db_connect (step 1, th_errno 13, action 3, level 1) [thxxhead.c 8437]

      M

      M Info for wp 0

      M

      M stat = 4

      M reqtype = 1

      M act_reqtype = -1

      M tid = -1

      M mode = 255

      M len = -1

      M rq_id = -1

      M rq_source = 255

      M last_tid = 0

      M last_mode = 0

      M rfc_req = 0

      M report = > <

      M action = 0

      M tab_name = > <

      M

      M *****************************************************************************

      M *

      M * LOCATION SAP-Server sapkalam_HYD_00 on host sapkalam (wp 0)

      M * ERROR tskh_init: db_connect

      M *

      M * TIME Sat Feb 11 14:46:50 2012

      M * RELEASE 620

      M * COMPONENT Taskhandler

      M * VERSION 1

      M * RC 13

      M * MODULE thxxhead.c

      M * LINE 8569

      M * COUNTER 1

      M *

      M *****************************************************************************

      M

      M Entering TH_CALLHOOKS

      M ThCallHooks: call hook >ThrSaveSPAFields< for event BEFORE_DUMP

      M *** ERROR => ThrSaveSPAFields: no valid thr_wpadm [thxxrun1.c 672]

      M *** ERROR => ThCallHooks: event handler ThrSaveSPAFields for event BEFORE_DUMP failed [thxxtool3.c 237]

      M Entering ThSetStatError

      M Entering ThReadDetachMode

      M call ThrShutDown (1)...

      M ***LOG Q02=> wp_halt, WPStop (Workproc 0 3020) [dpnttool.c 346]

      Please suggest me if you find any fix. Any help would be appriciated.

      Many Thanks,

      Vinod

  • avatar image
    Former Member
    Feb 12, 2009 at 04:13 AM

    Hi Vinod,

    Again you are saying that facing same error? But here in your dev_w0 log that issue was not there.

    If you are getting the same at R3trans -d, Just correct all errors as shown in dev_w0.

    Means here i am able to see the first error as couldn't read V$INSTANCE sql error 942.

    This is related to correct schema owner, now you are using the owner which in not exactly the same as your database. You need to set the same with correct one. You can correct these errors with SAPNOTE 400241.

    And after that upgrade your kernel with correct one.

    Regards

    Nick Loy

    Add comment
    10|10000 characters needed characters exceeded