Skip to Content
avatar image
Former Member

RFCIO_ERROR_SYSERROR

Hi all,

I have the following problem:

I have two SolMan Systems, one for tests and one productive.

The test system was installed under a 32-bit Win-OS and the productive under a 64-bit Win-OS. To get a identical System landscape we migrated the test system also to 64-bit. During that weu2019ve changed the hostname of the test system.

We use the productive System for our central system monitoring.

Now I have the problem that the productive System always tryu2019s to connect to the old test system with the old hostname.

Here is what the dev_rfc trace says:

  • Trace file opened at 20090116 144246 W. Europe Standard Time, SAP-REL 700,0,159 RFC-VER U 3 981833 MT-SL

======> CPIC-CALL: 'ThSAPOCMINIT' : cmRc=20 thRc=236

SAP gateway connection failed. Is SAP gateway started?

ABAP Programm: SAPLSALK (Transaction: )

Called function module: RFC_SYSTEM_INFO

User: SAPSYS (Client: 000)

Destination: hasssolt_SMT_00 (handle: 4, , {81D3E3DD-FE9C-F1FB-BD06-00145E2A367D})

Error RFCIO_ERROR_SYSERROR in abrfcpic.c : 2323

CPIC-CALL: 'ThSAPOCMINIT' : cmRc=20 thRc=236

SAP gateway connection failed. Is SAP gateway started?

HOST =xx.xx.xx.xx

SERV =sapdp00

Hasssolt is the old hostname

I also get a lot of SAP-Basis System: Operating system call connect failed (error no. 10060) errors

In the application log of the OS and SysLog.

Iu2019ve deleted all RFC Dest. with the old hostname

I also changed the System in TA SMSY and in the hosts file

I really donu2019t know why I get this error.

Any ideas?

Regards

Mario

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Jan 17, 2009 at 09:03 AM

    You have deleted the RFC hasssolt_SMT_00 from the production system. You would have created <new solman test host >_SMT_00.

    Did you assign this as the RFC destinatination for system monitoring in SMSY transaction in production solution manager..? You can check that in solution manager, SMSY. Select the system, Select the client in the clients tab on the right hand side. Click "Check RFC destinations". In the pop up that you get, is the checkbox "Assign RFC Dest for system monitoring" checked.

    If yes, What is the RFC assigned..?

    Regards,

    Anish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 19, 2009 at 10:27 AM

    Hi Anish,

    after i've installed the new SolMan Testsystem i've deleted the old SMT System in SMSY

    and created the new one, also i've generated all the needed RFC Destinations

    The RFC Destiantions für System Monitoring are

    SM_SMTCLNT100_READ and SM_SMTCLNT100_TRUSTED.

    There is no RFC hasssolt_SMT_00 in SM59

    I really don't know why the productive SolMan trys to connect the old SolMan every 5 min.

    Regards

    Mario

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Can you check one thing. Go to RZ21 in solution manager. In the section "topology"of the screen select system overview and click "Display over view". And verify the entries. Do you see old RFC mentioned somewhere..

      I would recommend you to perform the step Assign and generate RFC destinations again, making sure checkbox Assign RFC for system monitoring is checked.

      Also..were you able to make out any background job in solman which ran in last 20 min, with a frequency of 5 min..?

      The program SAPLSALK mentioned in the log is a function module for data collection and related activities which CCMS do.

      Regards,

      Anish

  • avatar image
    Former Member
    Jan 19, 2009 at 01:42 PM

    Yes, we use the SLD of the productive SolMan as central SLD, but I've also deleted the old System and registered the new SolMan test system on the SLD.

    Here is a entry of the dev_rd tracefile:

    *****************************************************************************

    *

    • LOCATION SAP-Gateway on host citssolp / sapgw00

    • ERROR partner 'hasssolt.sap.grammer.world:sapgw00' not reached

    *

    • TIME Sun Jan 18 12:37:27 2009

    • RELEASE 700

    • COMPONENT NI (network interface)

    • VERSION 38

    • RC -10

    • MODULE nixxi.cpp

    • LINE 2823

    • DETAIL NiPConnect2

    • SYSTEM CALL connect

    • ERRNO 10060

    • ERRNO TEXT WSAETIMEDOUT: Connection timed out

    • COUNTER 888

    *

    *****************************************************************************

    GwTraceHdlInfo:

    HANDLE = 71

    TIME = Sun Jan 18 12:37:07 2009

    SOCKET = 264

    STAT = NI_CONN_WAIT

    TYPE = STREAM IPv4

    OUT = 0 messages 0 bytes

    IN = 0 messages 0 bytes

    LOCAL = 0.0.0.0:2223

    REMOTE = -

    OPTIONS = BUFFERED

    ni hdl = 71

    type = CLIENT

    net_stat = CONNECT_TO_REM_GW_PENDING

    hostaddr = xx.xx.xx.xx

    opcode = NORMAL_CLIENT

    conn opcode = REMOTE_GATEWAY

    conn vers = 0

    index = 14

    data = 0000000000000000

    ext_info = 000000000331CAB0

    offset = 0

    rest_len = 0

    snc_forced = 0

    remote gateway infos:

    hostname =

    hostaddr = xx.xx.xx.xx

    service = sapgw00

    tpname = sapdp00

    Sun Jan 18 12:42:27 2009

    ***LOG Q0I=> NiPConnect2: connect (10060: WSAETIMEDOUT: Connection timed out) [nixxi.cpp 2823]

    • ERROR => NiPConnect2: SiPeekPendConn failed for hdl 119 / sock 1932

    (SI_ECONN_REFUSE/10060; I4; ST; 10.18.11.64:3300) [nixxi.cpp 2823]

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 26, 2009 at 02:50 PM

    Hi Anish,

    the Problem is solved.

    There was an old entry in RZ21 -> Availability Monitoring -> configure CCMS Ping Availability.

    Thanks for your help

    Best regards

    Mario

    Add comment
    10|10000 characters needed characters exceeded