Skip to Content
avatar image
Former Member

Guest Access Not working on HCP Portal Site

Hi Experts,

I have created a free-style site using HCP Portal service and deployed a number of SAPUI5 applications. I have added all the apps to the "Guests" catalog. But When I publish the site and try to run in incognito or in any other browser which does not have my HCP login info, the site does not open and I get the below error in the networks Tab

Below is the screenshot with catalog Guest. The App brsdemoChartMaster is added to this predefined guest Catalog

Am I missing any steps in the Process?

Any help is appreciated.

Thanks in Advance,

Deepak

z4deg.png (53.2 kB)
oleyv.png (60.4 kB)
dkmgh.png (15.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Nov 20, 2016 at 12:47 PM

    Hi Deepak,

    HCP have recently added a new security constraint (documented in their release notes), which requires applications and widgets to "declare" the fact that they're available for non-authenticated access. Therefore, while your portal site allows Guest access, your non-out-of-the-box applications should also allow it.

    This can be done by adding the property "authenticationMethod": "none" in your application's neo-app.json. More information: https://help.hana.ondemand.com/help/frameset.htm?de16793b391a4bcfae6096f34433de76.html

    Regards,

    Guy

    Add comment
    10|10000 characters needed characters exceeded