Skip to Content

Release Strategy in purchase order document type

Hi Gurus..

I'm tring to tweak the single RS in the system.

I've set the charcteristic using table CEKKO field BSART, restriction 032, I've set two document types as the Characteristic Value (ZLOG - ZADM). Then I´ve set the class with this characteristic, Created Release Groups & linked to class , Created Release Codes, Release Indicator, and Set up strategies

.. but It doesn´t pick any release strategy.

The funny thing is if I delete the document types values entered in CL20N it works for all doc typs, but if I set the docs types that it should take to pick the RS it doesn't work at all...

Please advice..

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Posted on Jan 15, 2009 at 07:43 PM

    I´m not such a abapper but I guess there is not values taken to ekko, does it ring a bell?

    BUKRS

    BSTYP

    BSART

    BSAKZ

    LIFNR

    SPRAS

    EKORG

    EKGRP

    WAERS

    BEDAT 00000000

    LLIEF

    KUNNR

    RESWK

    LBLIF

    INCO1

    KTWRT 0.00

    LIFRE

    WERKS

    MATKL

    LTSNR

    USRC1

    USRC2

    USRN1 0000000000

    USRN2 0000000000

    GNETW 0.00

    SUBMI

    MEMORY

    KONNR

    REVNO

    PDUMMY

    KDATB 00000000

    KDATE 00000000

    EBELN

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      hello there,

      Alrite, so this is what I want you to do

      go to your characteristic in CT04- remove the restriction. make sure yoiu have multiple values in the basic data.

      Check your assignmnet in cl02.

      go to cl24, and maintain teh char. values as ZLOG; ZADM. Just like it is written here

      and try again.. THis is for the PO.. ain't it.. just curious

  • author's profile photo Former Member
    Former Member
    Posted on Jan 15, 2009 at 06:44 PM

    Not sure how you did it.. but make sure you do not have the setting unchecked for "Not ready for I/p" in CT04.. additional data. Delete the char. values if you maintained any

    Go to CL24N and enter all associated values for the characterisitrc values.. for the class

    It shoud work

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 15, 2009 at 07:07 PM

    Thanks Pavan foy your replay, unfortunately the check is already set, and the value in CL24N is also associated.

    I just don't know what more I can do....

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Do this,

      Go to se37

      Open ME_REL_STRATEGIE_EKKO, hit display

      Put a breakpoint(stop button) at MOVE i_cekko_new TO cekko`.

      open me21N and create PO, look at the contents of The CEKKo table.

      That would tell you where you are going wrong

  • author's profile photo Former Member
    Former Member
    Posted on Jan 15, 2009 at 10:41 PM

    The Bottom line is you can not enter the value if char is (ZLOG - ZADM)

    you have to enter one by one means

    Suppose your Char is Doctype

    Char Value

    Doctype ZLOG

    ZADM

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 16, 2009 at 03:26 AM

    Assign the Char Values ZLOG and ZADM in the Following way in CT04

    Char (Po_doc type supoose)

    Values ZLOG, ZADM

    You shoudnt assign like ZLOG-ZADM

    In CL24N assign the Values one by one for eg :

    ZLOG

    ZADM etc...

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 16, 2009 at 03:10 PM

    Hi Guys..

    thanks for your replays

    First the obvious:

    @Charly and Kalyanji: I'm not using ZLOG - ZADM in the sime line or field, it was just an example of char values.

    @Pavan: despite I'd tried every thing you said, I did it again, with the same result. I guess there is no customizing errors here, I'll start to search if a note or SP is needed..

    You deserve some points for your good will and fast answer...

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.