Skip to Content
avatar image
Former Member

Message Stuck in Outbound queue

Hi Guru's,

I am having difficulties with messages which get stuck in the inbound and outbound queue.

While reading some threads I did the following:

For the inbound queue's I have used the transaction SXMB_ADM, registered all queue's and activated it. Then the problems on the inbound side are gone.

The problem on the outbound queue's is still there. The message comes in the queue and I need to manual resend the message. (There was no error). How can I set it up in such a way that the message doesn't get stuk in the outbound queue.

Best regards,

Guido Koopmann

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jan 15, 2009 at 09:38 AM

    Hi Guido,

    usually they shouldnt stuck there, may be the receiver wasnt avaiable. In that cases they will be reschuled like configured in SMQR. You should find out the reason for stucking.

    You can schedule certain reports for rescheduling of FAILED messages, please find detailed informations in Naveens nice blog [XI : How to Re-Process failed XI Messages Automatically|] [original link is broken] [original link is broken] [original link is broken];



    Add comment
    10|10000 characters needed characters exceeded

  • Jan 15, 2009 at 09:54 AM


    Sometimes it happens due to cache refresh error. Check transaction SXI_CACHE.

    and run the delta cache refresh using:

    Runtime Cache -> Start Delta Cache refresh.


    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 15, 2009 at 10:08 AM

    Hi Koopmann,

    When ever QUEUES are struck we need to check in SMQ1(Outbound) & SMQ2(Inbound) transactions. Depends upon importances of the message, we need to delete the message from the queue(because we need to processes remaining messages).then that delete the message we can resend from sxi_monitor.

    Thanks & Regards,

    Sateesh N.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Koopman

      I wouldnt recommend deleting messages in SMQ1 or SMQ2 as it may lead to inconsistency. If you need to remove a message from the inbound queue, then use the save feature instead. Then you can examine the message in SMQ3 afterwards.

      Best regards,


  • Jan 15, 2009 at 10:18 AM


    You can schedule the jobs

    · RSARFCSE: Restart an LUW (background job)

    · RSARFCEX: Restart tRFC LUWs (background job)

    · RSQOWKEX: Restart QOUT qRFC LUWs

    · RSQIWKEX: Restart QIN qRFC LUWs

    And also make sure that you have set QRFC_RESTART_ALLOWED to value 1 in Integration engine settings in SXMB_ADMIN.


    Add comment
    10|10000 characters needed characters exceeded