Skip to Content
avatar image
Former Member

SAPUI5 Lib upgrade from 1.28 to higher on NW 7.31

I wish to upgrade the SAPUI5 libraries from 1.28.22 to higher.

Is it possible to upgrade library without upgrading NetWeaver? And upto which lib.version I can upgrade with NetWeaver 7.31?

Current system environment:

NetWeaver Version is 7.31.

UI5 addon 1.0

Ehp version 6

Could anyone pls guide me on the same.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Nov 08, 2016 at 12:49 PM

    Yes it is possible to upgrade SAPUI5 without upgrading SAP NW AS. In case of NetWeaver Version 7.31 you need to install UI Add-On 2.0 for NW ABAP to get the next innovation cycle after 1.28 up to 1.38, which is the current stable release. Please note that if you want to go beyond SAPUI5 1.38 you need to upgrade to NW ABAP 7.40 or higher as there are no further deliveries planned for lower NW ABAP release level. Upcoming SAPUI5 releases are only shipped via component SAP_UI. More details on the maintenance and update strategy of SAPUI5 can be found in note 2217489.

    Add comment
    10|10000 characters needed characters exceeded