Skip to Content
author's profile photo Former Member
Former Member

You do not have authorization for InfoCube XXXX (BEx Analyzer Error)

Hi All,

I have the following error message when I tried to open up a query in BEx Analyzer.

Diagnosis

You do not have authorization for InfoCube 'ZFLIGHT_MODEL'.

System Response

The current activity was terminated.

Procedure

You require authorization for authorization object Data Warehousing Workbench - InfoCube with InfoArea 'ZFLIGHT_MODEL', InfoCube 'ZIC_SBOOK', InfoCube-subobject 'DATA' and activity '23'.

My Objective

These are the steps that I have taken to create the role. My objective is to restrict the user from executing the other InfoCube query but are only authorized to execute the query based on authrization ZSFLIGHT created in Step 1.

Step 1:

Create an authorization called ZSFLIGHT with the following values:

0TCAACTVT EQ 03

0TCAIPROV EQ ZIC_SBOOK (which is my InfoCube)

0TCAKYFNM CP *

0TCAVALID CP *

ZCARRID CP * (My authorization relevant InfoObject)

Step 2:

Created a role by using the template S_RS_RREPU

Step 3

Modify authorization object S_RS_AUTH to remove 0BI_ALL and add authorization ZSFLIGHT created in Step 1.

Step 4

Inactivate authorization object S_RS_ICUBE.

The reason for doing so is because as understand in SAP NetWeaver 04s it will not go through this authorization object checking instead will use authorization object S_RS_AUTH.

Step 5

Generate the profile and assign the role to the user.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jan 15, 2009 at 08:46 AM

    Hi All,

    I have resolved my issue. It seems that there is a setting in SPRO that let you choose which kind of authorization method that is used when validating users authorization.

    Option 1: Obsolete Concept with RSR Authorization Objects

    Option 2: Current Procedure with Analysis Authorizations

    It seems our server is based on Option 1 and I have changed it to Option 2 and it is now working.

    Thanks

    David

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.