Skip to Content
0
Former Member
Jan 14, 2009 at 10:35 PM

Report does not prompt for parameters when SeparatePages=False

23 Views

Hi all. We are using CR2008 Basic w/SP1 along with VS2008. Within our application, reports pull up fine and prompt for parameters using the CrystalReportViewer against the web service. SeparatePages is set to True. We want to change SeparatePages to False, but when I do that any report that should prompt for parameters is not.

The reports were created in CR 8.5. We have upgraded them to CR2008 (open, refresh, save) which has greatly increased performance. With some further testing, I've discovered that if I take a report that doesn't currently have any parameters and add one via VS2008 report designer, it WILL prompt for the parameter when I run it in our application with SeparatePages=False.

So I'm leaning that the problem has to do with the reports originally being created in 8.5. I've tried modifying an existing report with parameters, deleting parameters and re-adding, but I still can't get these to prompt for parameters with SeparatePages=False.

Again, these same reports prompt for parms and work fine as long as SeparatePages=True. I'm hoping someone might be able to shed some light on this. There are over 400 reports so re-creating them from scratch under CR2008 will be a painful option 😊

If I need to provide any additional information just let me know. Thank you!

Sheila