Skip to Content
avatar image
Former Member

Problem in the RuntimeWorkBench, Adapter Engine

Hi Experts,

In the RWB > Component Monitoring >Adapter Engine if i double click on this, it is showing the following error:

CCMS Status: Last Retry Jan 14, 2009 10.42.32 AM CET

Ping Status: HTTP request failed Error Code: "401" Error message "Unauthorized[http://<hostName:Port Number/AdapterFramework/rtc]"

Last Retry Jan 14, 2009 10.43.57 AM CET

Self-Test Status: HTTP request failed Error Code: "401" Error message "Unauthorized[http://<hostName:Port Number/AdapterFramework/rtc]"

Last Retry Jan 14, 2009 10.44.17 AM CET

Ping Status & Self-Test Status trafic light colur is RED.

and also iam not able to open Message Monitoring it is asking 3 times user id and password finally it is displaying Unauthorized error.

It is production system, can any body help on this issue

Regards

Rohit

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Jan 14, 2009 at 07:41 PM

    Apparently you don't have enough authorization to access RWB, ask your basis team or security team to assign the following user roles to you:

    SAP_XI_MONITOR

    SAP_XI_MONITOR_ENHANCED

    also SAP_XI_DISPLAY_USER if you want to view IR and ID objects

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Jayson,

      Previously iam opening all components in RWB i have the roles, No one is able to open the Monitoring components in my team same error for all the persons.

      Regards

      Rohit

  • Jan 15, 2009 at 04:07 AM

    Hi

    Refresh your Full CPA Cache using URL

    http://<HOST>:<JavaPort>/CPACache/refresh?mode=full

    using user PIDIRUSER.

    Check this blog for 401 Error

    /people/krishna.moorthyp/blog/2006/07/23/http-errors-in-xi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 15, 2009 at 04:12 AM

    Hi Rohit,

    As Jayson said it is Authorization issue for you I mean User. Better contact your Basis team to double check all the roles that are assigned to your user.

    Best Regards

    Praveen

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 15, 2009 at 04:53 AM

    Hi Rohit

    for not able to open Message Monitoring

    Check if you have Runtime workbench access. You will require to have SAP_XI_MONITOR role authorization with your user id.

    also Check if the XI users (in ABAP) on the system running the SLD are locked. If some are, unlock them.

    There is a Monitoring Guide avaiable which will be very useful for you. Please check the User Profile settings described in it.

    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/0b4580be-0601-0010-d3ad-bd6ce51ae916

    There is also a post:

    Adapters not working, SLDAccess msg in adapter monitor

    take help of this post also

    error-httprespstatuscodenotok-401-unauthorized

    for HTTP request failed Error Code: "401"

    check if user: XIRWBUSER is not locked in R/3

    also check if you got a correct password in the XI exchange profile :

    com.sap.aii.rwb.serviceuser.name

    com.sap.aii.rwb.serviceuser.pwd

    com.sap.aii.rwb.serviceuser.language

    also try Changed pw in AE and connection is should work

    Regards

    Abhishek

    Edited by: Abhishek Agrahari on Jan 15, 2009 5:55 AM

    Add comment
    10|10000 characters needed characters exceeded