Skip to Content
author's profile photo Former Member
Former Member

Data of Appendfield missing after extraction to BI

Hi!

I have created a new datasource (zcostelmnt_attr) in the ERP-system. Its a copy of the standard datasource with an extra appendfield. Appendstructure, extractstructure => everthing is fine. The new

field is visible in the ERP and BI system. The datasource is displayed correct in the BI system.

The new field is filled in the customer-exit ZXRSAU02.

--> it works and you can see the correct result in the extractor-checker (RSA3).

The problem: After running the extraction in the BI System, you can see all "standard" data, but the data in the new field is missing in the PSA.

I've tried everything: delete dsou; created new; check all flags (its not hidden); generated new,...

???

Have you any ideas?

Thanks!!!

greets

chris

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 14, 2009 at 07:50 PM

    Hi Chris,

    This could be because of authorizations. The remote user in the ERP system should have the following authorizations;

    S_BI-WX_RFC and S_BI-WHM_RFC.

    The results in RSA3 can be different as the user runs this transaction in dialog. See the notes 538052 and 150315 for more information on the authorizations for your remote user.

    Best Regards,

    Vincent

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 14, 2009 at 05:44 PM

    Hi,

    Reactivate the append structure and the extract structure. Then reactivate the datasource and replicate on the BW side.

    See if that works if you haven't tried already.

    Cheers,

    Kedar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 15, 2009 at 08:57 AM

    Hi

    Recheck your entire flow on R/3 side again ( You should save the CMOD code once you appended the code)

    Hope you can see the Appended Field on BI side.

    Have you Replicated the Data Source for changes-- If yes -- If it is a Master Data Object you need to Upload the Data into that separately first before Transaction data.

    Hope it helps

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 15, 2009 at 09:06 AM

    Hi,

    Go to PSA mange->select DP>Sttings->Layout->Change--->select field from Coiumn set to displayed Column.

    Then check u will get that fields,

    Rgds,

    Satya

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 15, 2009 at 10:31 AM

    Hi Chris,

    Glad to hear it is working. Please don't forget to give some points for useful answers!

    Best Regards,

    Vincent

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.