Skip to Content
0

Webi Export to xml

Nov 08, 2016 at 09:01 AM

74

avatar image
Former Member

We are running BOE 4.1 SP6

We need to export a webi report into XML format. A sql script gathers the data

and in the script we are using the T_SQL command FOR XML to convert the result to XML.
In SQL Studio everythings work fine. I can copy the result, paste it in notepad, save it with the extension XML and it works.

When I schedule the WEBI report I use "plain text" as format , do not add the extension, but in the filename I add manually ".xml".
This also works correct. When I open the file I see XML, but the only problem that the file size is limited to 65kb. The data is truncated. How can I increase the file size?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Jyothirmayee A Nov 08, 2016 at 06:48 PM
0

Hi,

You can change the settings at Registry Editor.

1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AOneBrokerService\Parameters.
2. Right-click and create a new DWORD called 'ResultFileSizeLimit'.
3. The value of this key is the size limit in bytes for generating reports. Change the default size. Increment the value as required.
4. Close the Registry Editor.

Thanks,

Jothi

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services I do not have the keys "AOneBrokerService\Parameters".

I added these and also created ResultFileSizeLimit. Restarted the servers and exported a file, but it is still limited to 65kb.

0
Jyothirmayee A Nov 16, 2016 at 08:34 PM
0

Hi,

where is this XML running on your local machine or server side?.

If it is server CPU then you need to apply the same settings on Server machine.

That might help.

Thanks,

Jothi

Share
10 |10000 characters needed characters left characters exceeded
Jyothirmayee A Nov 16, 2016 at 08:34 PM
0

Hi,

where is this XML running on your local machine or server side?.

If it is server CPU then you need to apply the same settings on Server machine.

That might help.

Thanks,

Jothi

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I scheduled the report so it is running on the server side. We have 2 BOE servers running as a cluster.
I made the changes in the registry on both BOE servers.

0
Jyothirmayee A Nov 17, 2016 at 08:49 PM
0

Hi,

was it successful?.

Thanks,

Jothi

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 21, 2016 at 07:33 AM
0

It was not succesfull. Still limited to 65kb.

Share
10 |10000 characters needed characters left characters exceeded