Skip to Content
0
Former Member
Jan 09, 2009 at 12:52 PM

BO XI 3.1 on Linux installation failure

19 Views

Hello all,

I'm trying to install BO XI 3.1 on Red Hat Linux, but after a (long) time the installation fails with:

[PostInstallScripts::WaitForCMS] CMS is not started, giving up

I'm installing using an Oracle database, without auditing, and on a Tomcat-only container. I tried the install both on RH 4 and RH 5 but it fails in the same way both times.

When I look at the tomcat configuration I see that:

- conf/server.xml has not been changed (it has the default port numbers instead of the port numbers I provided during installation

- the tomcat/webapps directory contains ONLY the webapps that are default in a tomcat installation, it does not contain the BO Webapps.

Since server.xml does not contain a Context definition either this will never start properly. I installer BO XI 3.0 earlier and that worked without (too many) problems.

I tried to find out what happens during installation, but the install scripts are such a mess of badly coded PERL, shell scripts and Javascript (!?!?!) that that is very hard; in addition all logging is completely useless since errors of helper code is nog logged.

Is there a way to complete this installation without problems? Has anyone succeeded in installing BO XI 3.1 on Linux?