Skip to Content

Document Template designer - ActiveX on IE 7 problem

Dear all,

I have problem on displaying Document Template for Word on WebUI (using internet explorer 7).

I created web service, activated it, and set it to Productive. Then I create document template,

using the web service. But after clicking on Start Designer button, new blank Word document is open.

But where is the XML ? I read on the help documentation that there is XML appear on the Word,

where I can choose the fields from web service (to be used on my Word template).

Another thing, I found that on my browser page, there is error saying :

Details ActiveX is disabled, but required for using this template.

In fact, I had set the browser ActiveX setting according to requirement.

I checked on some sap notes (including 1018674) but still same problem.

Kindly advice if you have encountered similar problem and resolved it.

Cheers,

Gun.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jan 13, 2009 at 01:29 PM

    This is the full list of browser settings. Check if you missed anything:

    ● To allow your users to export the content of a result list to Microsoft Excel, ensure that the browser settings under Tools ® Internet Optionsu2026 ® Security ® Custom Levelu2026 are as follows:

    .NET Framework-reliant components:

    ○ Run components not signed with Authenticode ® Enable

    ○ Run components signed with Authenticode ® Enable

    ActiveX controls and plug-ins:

    ○ Download signed ActiveX controls ® Enable

    ○ Initialize and script ActiveX controls not marked as safe ® Enable

    ○ Run ActiveX controls and plug-ins ® Enable

    ○ Script ActiveX controls marked safe for scripting ® Enable

    Downloads:

    ○ File download ® Enable

    Miscellaneous:

    ○ Installation of desktop items ® Disable

    Scripting:

    ○ Active scripting ® Enable

    ○ Allow paste operations via script ® Enable

    ○ Scripting of Java applets ® Disable

    ● To enable groupware integration, adjust the browser settings under Tools ® Internet Optionsu2026 ® Security ® Custom Levelu2026 as follows:

    ActiveX controls and plug-ins:

    ○ Download unsigned ActiveX controls ® Prompt.

    ○ Initialize and script ActiveX controls not marked as safe ® Enable

    ○ Run ActiveX controls and plug-ins ® Enable

    Further Settings

    In addition to adding SAP CRM on-demand solution to the list of trusted sites and checking that the security settings are correct, the following browser settings are required.

    ● Adjust the browser settings under Tools ® Internet Options ® Advanced as follows. These settings are relevant for the e-mail inbox in SAP CRM on-demand solution:

    Browsing

    Unmark the following checkbox:

    Show friendly HTTP error messages

    HTTP 1.1 settings

    Mark the following checkboxes:

    ■ Use HTTP 1.1

    ■ Use HTTP 1.1 through proxy connections

    ● To enable all the user interface texts to be displayed correctly on the screen, ensure that you make the necessary language settings for the browser. You do this by choosing Tools ® Internet Optionsu2026 ®Languagesu2026 and then selecting the appropriate language.

    ● Popup Blockers

    If you have installed any popup blockers such as those provided by some search engines, your users may not be able to log out of SAP CRM on-demand solution correctly. Either you should remove or disable the popup blockers or the blockers should be instructed to allow popups from SAP CRM on-demand solution. This is also the case for popup blockers that are included now in newer versions of Microsoft Internet Explorer.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      I've solved my issue. The reason of my problem was that I used Office 2010 and CRM 7.0 EhP1. In this case the grey blank word doc is normal and I shall open/download the template directly.

      Furthermore the Office 2010 doesn't support XML if I am not wrong so I had to use Office 2007 instead.

      BR,

      G.

  • Jan 12, 2009 at 10:35 AM

    Hi,

    I sometimes had this issues as well. This usually disappear once I add the SAP server to the trusted sites and enable "Allow unsecure Active X Scripts"

    cheers Carsten

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 14, 2009 at 03:46 PM

    Hi,

    According to this error: Details ActiveX is disabled, but required for using this template.

    I had the same issue, but after installing adobe liveclycle designer it disappeared.

    Regards,

    Nanda

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 06, 2011 at 10:34 AM

    Hi ,

    I am trying to create a document template with a web service and facing a similar issue as yours.

    After filling all required data and the Webservice , when i click on start the designer , a new MS Word window opens which is Blank and does not have any XML pane to the right as described in all documents.

    I have maintained all the required activeX settings also.

    I believe you have resolved this issue , Please let me know how i can show the XML Pane in Word .

    Thanks !!

    Add comment
    10|10000 characters needed characters exceeded