Skip to Content
avatar image
Former Member

at the end of line # is coming in output file at application directory

Hi experts,

I am doing a file to file tunneling in which from a file server I am picking the file and putting it into SAP application server nothing is done in IR .However when the file is reaching in application server its end seprator is coming as # .I am surprised from where the #is coming at the end of every line.When i am dowloading the same file to my local directory in that file # is not there.

Please help me as my client is not accepting the file with endsepeartor as # .

Might be # is coming as the apllication server is in uniq env . But how to get rid of it .Please guide me with whatever input you have in this regard.

Regards,

Neha

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 09, 2009 at 09:05 AM

    Hi

    Look this thread might help you

    deleting-null-character-in-source-file

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 09, 2009 at 09:53 AM

    in the file receiver adapter, for the parameter File Type what have you given?

    Try the various options (binary and Text) and check if it alters the data.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Neha,

      in your source file, # should not be there..........process it by sender file adapter..............

      in receiver file adapter, try Text and do not specify any encoding.............if this does not work, then try receiver file adapter with Text and encoding as utf-8.

      Regards,

      Rajeev Gupta