Skip to Content
author's profile photo Former Member
Former Member

IMG Settings for "Define Settings for Attachements" SRM 5.5

Hi!

I hope some can help me too.

I use SRM 5.5 and want configure also attachement transfer from SRM to R3 (700).

I have implemented the

BAPI - BBP_CREATE_BE_RQ_NEW

with the method

FILL_REQ_INTERFACE

and the statement

CV_ATTACH_TRANSFER_ACTIVE = 'X'.

I have also done the settings in DC10, DC20, DC30.

But my Problem is that i dont get a attached document in R3 if i look in TA (ME23N).

In SICF i have configure the docserver with ALIAS.

In SMICM i get no error message if i start with NONE entry in field RFC Connections.

Can anybody give me help with the IMG settings in "Define Settings for Attachements"?

i think in this settings i have some to fill out but dont know really what!

please can someone help me with this problem.

Thx

Wolfgang

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2009 at 09:30 AM

    Hallo Wolfgang,

    in the BADI-implementation you should also provide reasonable values for the fields BE_DOC_TYPE and BE_STORAGE_CAT of the structure CS_CTRL_ATT.

    Regards,

    Armin

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2009 at 11:19 AM

    Hi and thx for answer!

    I have now added in the BAPI the 2 statements

    BE_STORAGE_CAT = 'DMS_C1_ST'

    BE_DOC_TYPE = 'SRM'

    and now i get in SAP Portal following error message if i want attach a file:

    The instruction at "0x0adca7b9" referenced memory at "0x00000000"

    The memory could not be read.

    After this i try it again without this2 statements and i get the same error message?!?

    So what can i do now?

    thx for any help

    br Wolfgang

    @ In the TA MN23n i look at the item position line for attached files but nothing their.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi again!

      For this updates i can attach file on order but after this i cant.

      This is very mysterious but i restore the server and than i will check all settings again.

      did you have a description for this settings or a checklist what i must check and where?

      thx

      br

      Wolfgang

  • author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2009 at 02:12 PM

    Hi Wolfgang,

    the BADI BBP_CREATE_BE_RQ_NEW is called just before the transfer of the RQ to the Backend, modifications made there cannot lead to the error mentioned above.

    If your Portal is up again, you should check again the DMS customizing in the Backend according to the config guide (number exit, user rights of the SRM Backend user, workstation application etc.).

    Is it possible to create a document in the backend manually ?

    Regards,

    Armin

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2009 at 09:00 AM

    Hallo Wolfgang,

    if the handling of attachments in SRM is correct (which means you are able to upload them correctly and so on) and you just are not able to transfer them to R/3, please take a look at this thread:

    attachments-with-follow-on-documents

    Especially the Debugging of the function modules BAPI_DOCUMENT_CREATE2 and CVAPI_DOC_CHECKIN in R/3 should give you hints.

    Regards,

    Armin

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.