Skip to Content
0
Former Member
Jan 06, 2009 at 07:18 PM

Strange Data Insight error: Port must not be empty in the source connection

27 Views

I installed Data Insight XI 3.0 (12.1) on Windows XP and created the metadata repository on MSSQL Server 2000 on the same machine. The engine and GUI were started OK. I can also create a new project, and a new connection to the "Northwind" database on the same MSSQL 2000 server. However, when I tried to run any profile task on any table, I got the following error in the engine's error log "Iqieng.log". I don't know why it complainted about the empty port number because the MSSQL server runs on the default port 1433. And I can actually open all tables and view the data in the project so the connection must be good. I tried to search the document and all options in the GUI, "iqi.ini" file, and even the registry but couldn't find where to set the host name and port number. Can someone shed light on this? Thanks very much!

********************************************************************

Mon Jan 5 2009 00:04:24.703000>

  • Thread <4688> Task bypassed; Port must not be empty in the source connection. Connection Name: <Northwind> DatabaseVendor: <SQL SERVER> DataSource: <SFON00460026A\SAP_DEFAULT> Host: <> Port: <>

  • Task: <DATAPROFILE1> PtkId: <12> PrsId: <23>

  • Location: RequestDispatcher::RejectRequest()

Mon Jan 5 2009 00:04:24.703000>