Skip to Content
author's profile photo Former Member
Former Member

Item Event - the given key was not present in the dictionary

Dear expert B1,

I have a problem on Incoming Payment.

After I Add new "Document Numbering" for all transaction (sales order, invoice, purchase order, etc) - (eq:start document number became 200900001), and all transaction used the document number that i created.

The problem is when i open incoming payment, the error message appear "Item Event - the given key was not present in the dictionary"

Does the experts have meet same problem with me?

Thank you for your help before.

- Hendra-

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jan 15, 2009 at 07:24 AM

    Dear P'Hendra,

    Since there is a word item event in the message, I suggest to ask the addon developer but for this, it is necessary to continue maintenance and support from SAP and the partner.

    you could also post the message in the SDK forum to have free support.

    Rgds,

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 13, 2009 at 06:43 AM

    Hi Hendra,

    From the Error message that is stated in the thread, it seems more like an error generated by an addon.

    The first step that I would recommend you to do is to "Try and reproduce the issue with the addon - turned off and/or unistall the addon and then try to reproduce the issue".

    If you are able to reproduce the issue without the addon, then please let u sknow the steps with which you are able to rperoduce this issue.

    If this issue is reproducible only with a particular addon, please contact the addon makers for this issue.

    Regards

    Arshdeep Singh Makker

    SAP Business One Forum's Team

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi, Arshdeep Singh

      Thanks for your advise,

      Before I posted it, I have tested the transaction without AddOn, so I have not the problem on incoming payment transaction.

      If our problem on AddOn, why the others transaction has not problems (outgoing payment, sales order, etc)?

      (ps: I do not have the source code AddOn, coz our implementator did not give the source code AddOn)

      I have backup transaction (30Nov2008), I restore it, so... no problem on incoming payment transaction.

      Do you have any idea about my problems? or SBO expert have meet same problem with me?

      thanks,

      + Hendra +

  • author's profile photo Former Member
    Former Member
    Posted on Jan 13, 2009 at 03:26 PM

    Dear Hendra,

    Since your add-on has problem, you have to contact the add-on provider. No one here can help you without add-on code.

    Thanks,

    Gordon

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.