Skip to Content
0
May 25, 2018 at 01:08 PM

Couple of issues with Sybase installed on Linux

527 Views

Hi, All,

Not too long ago I downloaded and installed Sybase 16 on my Gentoo Linux box. The install went thru fine but when I tried to start and work with it I hit couple of issues.

1. I'm a developer and in my program I will try to connect to Sybase server thru the ODBC interface. I have unixODBC package installed so I created the appropriate DSN and started my software.

Unfortunately it failed to connect saying that the file /opt/sap/DataAccess64/ODBC/lib/libsybdrvodb.so is not found. The file however was present on my system and upon examining it with ldd I found that there is a missing "so" file. So I had to manually modify the LD_LIBRARY_PATH environment variable in order to fix dynamic linking.

It would be nice if the installer checks if the ODBC driver is being installed do that for me.

2. I have a big script that suppose to create a database and populate the data in thedifferent tables. However trying to create the database and running the script fails. I have a screenshot of the error and the script itself. I can send in both in order for someone to reproduce the problem. The crash occurred inside the GUI iSQL software. I started it, loaded the script and then tried to execute it.

I tried to contact someone fronm the technical support but unfortunately my try went un-noticed.

3. Going back to my program.

I created the database, couple of tables and put some data in coupple of them (just reduced the big script from issue 2 to bare minimal). Then I ran my software. Once again - I have a source code so I can send it to people to perform some test. But in order to test the cfonnectivity to the server I started the iSQL program from the unixODBC and tried to connect. The connection was successful, but when I tried to perform a simple SELECT statement I received a "Segmentation fault" on the console from the unixODBC.

Trying to work with Sybase iSQL there is no problem. Everything works.

As I said - I have all the source code and all configurations in order to reproduce all those 3 issues.

It would be nice if I get contacted by one of the Sybase developers for all those test cases, but if not I can live with some developer (not the DBA) to contact me to give the files and the complete scenarios.

All this was done on the Gentoo Linux with the Sybase 16 Developer Edition.

Thank you and sorry for the long post.