Skip to Content
avatar image
Former Member

Restrict users to only see their own messages in CRM_DNO_MONITOR

In our solman, we have connections to several satelite systems of different customers. In the messages viewer crm_dno_monitor, we want to have some restrications on different customer users so in the T-code they can only see the messages related to their company. Are there any ways to achieve this function? Hope for some ideas and details about it, thank you!!

Best Regards,

Karl He

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jan 04, 2009 at 05:28 PM

    Hi,

    To restrict the users only see the messages related to their company.

    Please contact your security team and explain the situation they can do it.

    Regards

    Sreedhar Reddy

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi, Reddy

      Thank you for your reply. But we don't have a security team, I have to do it myself, so would you please provide some more details about the solution to the question?

      Regards,

      Karl

  • avatar image
    Former Member
    Jan 05, 2009 at 05:10 AM

    Dear Friend,

    To achieve this.

    Create a variant choosing MINE tick box...this will display tickets which are for the resp assigned employee.

    Now create a Z or Y Transaction code for this variant from SE93

    (its easy to do this can search forum)

    Finally create a role assign this to ur user's.

    Pls assign pts.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you all.

      These really work. But we want to let the customer processing messages in the Work Center_ Incident Management Workcenter.

      And I met another problem, first there is a search function in it, it will enable the user to find all the messages in solman, this is not what I want.

      Second, when I tried to create message there it said "You are not assigned to any iBase entries. Please contact your system administrator." In fact, I have already assigned a BP to the user, why this error appears?

      Third, when I try to process the message in the work center, I click "Message" button in the navigation area, then select the message, but all the 'confirm', 'reply' button are in grey, I can't process the message at all.

      Some more ideas about it?

      Best Regard,

      Karl

  • Jan 05, 2009 at 06:55 AM

    Hi,

    Please check these authorization objects.

    CRM_ORD_PR , CRM_ORD_OP

    Also check the note 621927.

    This should solve your problem.

    Feel free to revert back.

    --Ragu

    Add comment
    10|10000 characters needed characters exceeded