Skip to Content
0

All servers on a node stopped

Nov 07, 2016 at 05:49 PM

166

avatar image

Hi experts,

we have a clustered environment with two nodes hosted on linux vm. Both the nodes are running SAP BusinessObjects BI Platform 4.1 Support Pack 5 Patch 4.

All the servers on node1 suddenly went to stopped state. They are all enabled but stopped. Not able to start them from CMC and restarting the SIA didn't help either. In the properties the error shown is:

  • The Server Intelligence Agent for this server is unavailable.

CMS trace log shows the following erorr:

oblistenermgr.cpp:1064:-: TraceLog message 1629 |0548b833-89a4-7a37-5e01-38fd51b82981|2016 11 07 12:19:21:802|-0500|Error| |>>|E| |cms_vmlshbobjp1d.CentralManagementServer|29069|47307902596864|| ||||||||||||||||||||||assert failure: (oblistenermgr.cpp:1064). (false : Error registering the local listener to server).

Node 2 is working fine. No issues at all.

Any suggestions on how to get the servers on node1 started?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Kuldeep Ghosh Nov 07, 2016 at 05:54 PM
1

Check the cms database connectivity from the server where BO services is stopped. My best guess is, that's the issue. From the error it appears that the TNS Entry is not able to communicate with oracle server.

Check the connectivity.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks for the response Kuldeep. Connectivity does not seems to be the issue..

0
Denis Konovalov
Nov 07, 2016 at 08:45 PM
0

run cmsdbsetup.sh on troubled node, check that everything look good there first. Then make sure that the posrts assigned to SIA and CMS are not in use by something else on that node.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

ran cmsdbsetup and everything looks fine. It brought up the cms db and cluster details. But how do I check if the SIA and CMS db ports are used by something else?

0

when SIA is not running you run OS command that shows which ports are used.

But truly, you should enable traces for SIA and CMS servers and look what's going on.

0
Ajay Gupta Nov 07, 2016 at 10:01 PM
0

Vineet,

Have you checked you make sure you have enough temp space for all the logs file being generated by BOBJ? Have you also checked to make sure have proper temp/working space for the OS as well? Have you checked to the space/size of your CMS database?

BOBJ servers will shut down if it does NOT proper temp space to work.

Regards,

Ajay

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Ajay,

Space/size doesn't seem to be the issue either. Checked the space utilized and its looks fine.

Filesystem Size Used Avail Use% Mounted on

/dev/mapper/VolGroup00-lv_root 25G 5.8G 18G 25% /

tmpfs 16G 0 16G 0% /dev/shm

/dev/sda1 485M 92M 368M 20% /boot /dev/mapper/VolGroup00-usrbobj 40G 23G 16G 59% /usr/bobj /dev/mapper/VolGroup00-oracle 4.0G 1.3G 2.6G 34% /oracle

/dev/mapper/VolGroup00-openc 4.0G 1.2G 2.7G 31% /openc

10.XX.XX.X:/BOBJ_dev/dev 150G 512K 150G 1% /BOBJ_dev/dev

10.XX.XX.X:/bobjdevshare 135G 90G 45G 67% /bobjshare

0
Mohan Babu Karamala Nov 07, 2016 at 11:43 PM
0

Hi,

- Check the file system /dev/shm maybe full,..

- Check the TNSNAME.ORA file and try R3trans -d

- Have you applied any kernel patch recently for your Linux OS,..?? Which Version of OS are you running ?

Thank you,

Mohan Karamala.

Share
10 |10000 characters needed characters left characters exceeded