Skip to Content
avatar image
Former Member

unable to shutdown application/database

I'm in a tough situation. I'm running ECC6 on Oracle10g on a Solaris 10 box

The home directory of user <sapsid>adm is lost & there is no backup for it . Hence I cannot log in as user <sapsid>adm and shutdown the application & database for backup

However in directory /sapmnt/PRD/exe I can see executables files stopsap , stopj2eedb & stopdb as seen below

root@PRD#pwd

/sapmnt/PRD/exe

root@PRD#

root@PRD#

root@PRD#ls -ltr stop *

-rwxr-xr-x 1 root root 49066 Jan 26 2007 stopsap

-rwxr-xr-x 1 root root 11119 Jan 26 2007 stopj2eedb

-rwxr-xr-x 1 root root 11119 Jan 26 2007 stopdb

is it safe to use these files to stop & start the application and database ?

is there a way round this. ?

Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 30, 2008 at 09:18 AM

    Try as per juan said.

    Try to login with ORA<SID> user then shutdown the db and take full backup of the system.

    And for the user id <SID>adm issue.

    Try to create new user id and then copy the env files from some other user id which is user for SAP system.

    and modify all the *.sh and *csh files.

    In which you have to mention the SID , oracle home, NLS settings.

    and after that shutdown the sap sys as usual.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 28, 2008 at 10:11 AM

    you could logon as ora<sid> and stop the database manually... then take a full offline backup of the DB.

    Regards

    Juan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      (A) Stoping the appl and CI server

      Login to SID<adm>

      Run the "stopsap r3"

      (B) Database shutdown

      Login to ora<SID>

      #sqlplus /nolog

      SQL> connect /as sysdba

      SQL> shutdown immediate

      Regards

  • avatar image
    Former Member
    Aug 28, 2009 at 04:24 PM

    it was a Solaris problem. I solved as follows

    Commented out 3rd line in the file /etc/auto_master i.e.

    +auto_master

    /net -hosts -nosuid,nobrowse

    #/home auto_home -browse

    Restart autofs service ie

    svcadm restart autofs

    the files (ie for SAP users SAPSID>adm & ora<SID> ) in the home directory reappeared

    Add comment
    10|10000 characters needed characters exceeded