Skip to Content
avatar image
Former Member

System copy error of init.ora

Hi,

I am doing system copy. My versions are ERP04, DB is oracle and OS is AIX 5.3

I have restored datafiles and others and also init<SID>.ora files

But I am getting an error

It is at step Oracle Preload Actions. It is giving me the following error:-

ERROR 2008-12-28 01:28:17

MDB-06177 Bad entry in the init.ora file: Bad parameter value. Starts

with '=' or white space or contains '(' or ')'. Line 15 near string ','.

ERROR 2008-12-28 02:26:45

MDB-06021 Could not read file: [/oracle/<SID>/920_64/dbs/initRD1.ora].

I am doing system copy. I have copied the init<SID>.ora file from too.

Line 15 is the line with parameter control files.

I have checked it and rewrote it manually, but it did not help.

I tried to remove *. from every paramter and restarted the DB and retried

installation, but it did not help.

I have searched for notes and on SDN but did not get anything.

I am not getting what can be the problem.

Kindly help

Regards,

Tajinder

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Dec 28, 2008 at 08:51 AM

    Pasting my init<SID>.ora file

    ########################################################################

    1. This init.ora profile is a transparent copy of Oracle spfile. #*

    2. It was created by BRCONNECT at 2008-12-26 04.00.45. #*

    3. Please do not change this file! Maintain only the spfile. #*

    4. You can use BRSPACE for the altering of database parameters: #*

    5. brspace -f dbparam #*

    ########################################################################

    *._b_tree_bitmap_plans=FALSE

    *._eliminate_common_subexpr=FALSE

    *._optim_peek_user_binds=FALSE

    *._optimizer_join_sel_sanity_check=TRUE

    *.background_dump_dest='/oracle/RD1/saptrace/background'

    *.compatible='9.2.0'

    *.control_file_record_keep_time=30

    *.control_files='/oracle/RD1/origlogA/cntrl/cntrlRD1.dbf','/oracle/RD1/sapdata1/system_1/cntrl/cntrlRD1.dbf',

    '/oracle/RD1/saparch/cnrtl/cntrlRD1.dbf'

    *.core_dump_dest='/oracle/RD1/saptrace/background'

    *.db_block_size=8192

    *.db_cache_size=429486243

    *.db_file_multiblock_read_count=8

    *.db_files=254

    *.db_name='RD1'

    *.dml_locks=4000

    *.enqueue_resources=8000

    *.fast_start_mttr_target=900

    *.hash_join_enabled=TRUE

    *.log_archive_dest='/oracle/RD1/oraarch/RD1arch'

    *.log_archive_start=true

    *.log_buffer=1048576

    *.log_checkpoint_interval=0

    *.log_checkpoint_timeout=0

    *.log_checkpoints_to_alert=true

    *.open_cursors=800

    *.optimizer_features_enable='9.2.0'

    *.optimizer_index_cost_adj=10

    *.optimizer_mode='choose'

    *.parallel_execution_message_size=16384

    *.parallel_max_servers=20

    *.pga_aggregate_target=572648325

    *.processes=92

    *.remote_os_authent=true

    *.sessions=100

    *.sga_max_size=858972487

    *.shared_pool_reserved_size=42948624

    *.shared_pool_size=429486243

    *.sort_area_retained_size=0

    *.sort_area_size=2097152

    *.star_transformation_enabled='TRUE'

    *.statistics_level='typical'

    *.timed_statistics=true

    *.transaction_auditing=FALSE

    *.undo_management='AUTO'

    *.undo_retention=43200

    *.undo_tablespace='PSAPUNDO'

    *.user_dump_dest='/oracle/RD1/saptrace/usertrace'

    *.workarea_size_policy='AUTO'

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 28, 2008 at 09:30 AM

    Hello Tajinder,

    can you please verify that there are no spaces at the end of the lines.

    If you are using VIM on unix then you can see some special characters very well.

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 29, 2008 at 12:18 AM

    hi tajinder,

    You cannot write init.ora manually or edit it directly. Use BRTOOLS to edit this parameter.

    You could also directly open it by using command :>brspace -f dbparam

    ardhian

    http://ardhian.kioslinux.com

    http://sapbasis.wordpress.com

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 06, 2010 at 03:08 PM

    Thanks for the solution. Even it worked for me.

    Add comment
    10|10000 characters needed characters exceeded