Skip to Content
author's profile photo Former Member
Former Member

Missing field in Idoc

Hello everyone.

There is an existing interface, witch has an IDOC that goes from SAP to NON-SAP system, that I had to modify, because we need to add a field in it and map it.

In IR I did all things that I must do.

In R3, the Idoc was modified.

When SAP sends the Idoc to XI, in TC WE02 we can see the new field outcoming but in XI doesnt appears.

I check with basis guys the TC BD64 and we "refresh" the idoc, but it's still not working.

I send the structure of the idoc into a XML to XI from an external program, and the new field appears (there weren't any problem with this). So it seems that the interface is ok from XI side.

Anybody knows why isn't appearing in XI this field when R3 sends the IDOC?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 23, 2008 at 02:03 PM

    Hi,

    Reload the IDOC metadata on XI System using IDX2 transaction code

    Go to IDX2 in XI system and import the Idoc.

    If the metadata already exists delete it and reload.

    Also make sure that,IDX1 entry is correct.

    regards

    Ganga

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 23, 2008 at 02:08 PM

    Hello,

    Delete the metadata from IDX2 and send new idoc from R3 system. New matadat will be updated in IDX2.

    Regards,

    Sreenivas.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 23, 2008 at 02:12 PM

    Hi,

    It seems that you have not updated the IDOC metadata in XI under transaction IDX2. This is very common mistake that after making the changes in IDOC strcture we forget to update the metadata.

    In IDX2 delete the old metadata and load it again.

    Regards,

    Sarvesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 23, 2008 at 02:38 PM

    You were right.

    I was missing that stupid thing.

    Thank you all very much!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.