Skip to Content
author's profile photo Former Member
Former Member

DMEE : Delete Trailing spaces in the output file..

Dear Friends

I am using a DMEE Tree t generate a payment file.

Everything is fine except that teh bank requires the trailing spaces to be deleted.

i.e. I am getting an output like below but with spaces in place of dots

:50H:/09618078222002EUR....................<CR/LF>

Sana'a............................................ <CR/LF>

:70:DMEE-TEST14.................<CR/LF>

Note:The dots represents spaces which I want to remove. The dots are added to show you the output...

The <CR/LF> is printing at the end of the field length. I mean if the field is 34 Chr long then the

<CR/LF> is getting printed at 35th Char irrexpective of teh field contents...

But the bank requires in the below format. i.e. remove the spaces thats all.

:50H:/09618078222002EUR<CR/LF>

Sana'a<CR/LF>

:70:DMEE-TEST14<CR/LF>

Can anyone help.

I am working on SAP 4.6C

Help will surely be reawrded....

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Dec 22, 2008 at 01:17 PM

    Hello Sam,

    I DO NOT know if i can make you understand the logic, but will give it a try 😊)

    The <CR/LF> is printing at the end of the field length. I mean if the field is 34 Chr long then the

    <CR/LF> is getting printed at 35th Char irrexpective of teh field contents...

    You define an element of length 35 char, then in the "Mapping Procedure" select the "Own Mapping (Atoms)" & set the "Atom Handling" as 01 (Concatenate values in element).

    Then create the ATOMS: one with the value "DMEE-TEST14" & the other atom with the value "<CR/LF>

    ". The output will be a concatenation of the two fields 😊)

    Did you get what i wanted to tell you 😊)

    BR,

    Suhas

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 22, 2008 at 12:55 PM

    Use CONDENSE statement to remvoe trailing spaces.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on 21 hours ago

    Just go to DMEE tree: properties. On tab Format attributes you have option Field type. Please choose field type 1 which means that fields are separated by delimiter.

    Field of Delimiter screen must be empty just like in photo below

    This will delete trailing spaces for all fields in output file.


    screenshot-1.png (38.4 kB)
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.