Skip to Content
author's profile photo Former Member
Former Member

Smartforms Declaration

I declared the following at Types tab:

TYPES: BEGIN OF gty_add,

LIFNR TYPE EKKO-LIFNR,

NAME1 TYPE ADRC-NAME1,

NAME3 TYPE ADRC-NAME3,

NAME4 TYPE ADRC-NAME4,

NAME_CO TYPE ADRC-NAME_CO,

STR_SUPPL1 TYPE ADRC-STR_SUPPL1,

STR_SUPPL2 TYPE ADRC-STR_SUPPL2,

STR_SUPPL3 TYPE ADRC-STR_SUPPL3,

POST_CODE1 TYPE ADRC-POST_CODE1,

CITY1 TYPE ADRC-CITY1,

BEZEI TYPE T005U-BEZEI,

LANDX TYPE T005T-LANDX,

VERKF TYPE EKKO-VERKF,

TELFX TYPE LFA1-TELFX,

EVTXT TYPE T027B-EVTXT,

END OF gty_add.

TYPES: gty_tadd TYPE STANDARD TABLE OF gty_add.

And the following at Global Data tab:

GT_ADD TYPE GTY_TADD

GWA_ADD TYPE GTY_ADD

At Initialization tab:

SELECT LIFNR

VERKF

INTO CORRESPONDING FIELDS OF TABLE GT_ADD

FROM EKKO

WHERE EBELN = EBELN.

When I activate it, error:

Field "GT_ADD" is unknown. It is neither in one of the specified tables nor defined by a "DATA" statement

Why do I get such message? Have I not declared correctly at Global Data? Please advise.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Dec 19, 2008 at 10:40 AM

    Hello,

    You have to add the table "GT_ADD" to the "Output Parameters" column under the Initialization tab 😊)

    It should solve ur problem.

    BR,

    Suhas

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 19, 2008 at 10:46 AM

    Hi,

    Have you added GT_ADD in the "Input Parameters" and "Output Parameters" section of the Initialization tab? If not, do so and you will not get this error.

    Best Regards,

    Ram.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 19, 2008 at 11:30 AM

    Hi,

    You have to declare GT_ADD as Output Parameter and EBELN as Input Parameter in the Initialization tab. Also you have to declare EBELN as Import parameter in Form interface

    like, EBELN TYPE EKKO-EBELN.

    I hope this is useful for you.

    Regards,

    Joan

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.