Skip to Content
author's profile photo Former Member
Former Member

'NO agent ready'

Dear All,

I am facing 2 problems in my workflow:

1.The first step which is an activity to determine the HR manager(I am not using rule for that).It takes almost 15

mins to execute.

2.After that it moves to the next step

which is again an activity for the manager decision and says no agent ready.For agent assignment i am passing the username prefixed with US.I checked the container at run time it contains the values but still says no agent ready.

Regards,

Geet Bijlani

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Posted on Dec 17, 2008 at 10:53 AM

    Hi,

    1. Does your first task get completed succesfully? I guess it must be a custom method. You can try first testing this method using the BO in tcode SWO1 and check if it works fine there and revert.

    2. Check if you have marked this task as general task. Go to your task --> Additional data --> agent assignment > Maintain agent> General task. Do this and see if the problem continues.

    Try diagnosing the workflow log in SWEL tcode.

    Regards,

    Raj

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 17, 2008 at 11:02 AM

    Hi,

    Are you using the same way in the first and second step to Determine the Agent ?

    If yes, Make it as general Task.

    If No, test BO Method whether you getting the agent.

    Regards,

    Surjith

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 17, 2008 at 11:03 AM

    Hi Geet,

    1. you are not using rule for the second step also?

    2. where you tested the workflow. in R/3 or by using WDJ or WDABAP.

    Regards

    SM Nizamudeen

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 17, 2008 at 11:18 AM

    Hi Geet,

    First of all just check the workflow diagnosis in Transaction SWUD ,and try to find out where is the problem.

    Problem can be in:

    1.)Agent assignment for tasks in TASK.

    2.) Check the Task

    Your Problem:For agent assignment i am passing the username prefixed with US.I checked the container at run time it contains the values but still says no agent ready.

    Ans: Check the container elements in the TASK that it has your username or not and proper binding of task and workflow is done or not.

    Hope it works

    Regards

    Sachin Sharma

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 18, 2008 at 05:39 AM

    Solved it myself...nothing technical about it...just a client problem

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.