Skip to Content
avatar image
Former Member

Error while opening Alert Configuration in RWB

Hi Everyone,

When I selcet Either Alert Inbox or Alert Configuration in Runtime Work Bench, I am getting error as

404 Not Found

The requested resource does not exist.

Do we need to configure/Deploy anything to access Alert Configuration.

Regards,

Varun

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Dec 17, 2008 at 05:32 AM

    Check SAP Note 750287.

    Regards,

    Prateek

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear prateek,

      Good Afternoon....!!

      I have executed the report "RSXMB_ACTIVATE_ICF_SERVICES" in ECC system in tcode se38.

      Later in PI system I have executed the tcode rz10 -->intance profile---->extended maintenance.

      Selected icm/server_port_0 and changed the parameter value toPROT=HTTP,PORT=80$$,TIMEOUT=30,PROCTIMEOUT=602.

      But still in PI JAVA STACK in rwb I'm finidn the same error 'HTTP 404 RESOURCE NOT FOUND' for alerts.

      Thanks and Regards,

      Rajesh PS

  • avatar image
    Former Member
    Dec 17, 2008 at 06:35 AM

    Hi varun

    This error occurs when the exchange profile contains the wrong HTTP port and host name for WebAs ABAP.

    The error also occurs if the host name is changed after the initial maintenance of the exchange profile. For example, the error occurs if a new host name is determined on a system that is operated by a hosting partner and that can be contacted from the customer network. In this case, the exchange profile must be modified as described below.

    Kindly Check the following property under "Runtime Workbench" in the exchange profile:

    com.sap.aii.rwb.server.centralmonitoring.httpport

    Hope after this your problem will be solved

    Regards

    sandeep

    Add comment
    10|10000 characters needed characters exceeded

    • Hi varun,

      Just check this:

      go to transaction SICF adn execute

      default_host->sap->bc->bsp->sap->alertinbox

      right click and test this service and also check this service is activated or not.. if not please activat it.

      Regards,

      Sachin

  • avatar image
    Former Member
    Dec 17, 2008 at 07:15 AM

    Varun,

    Perform following steps. , if not performed earlier :

    1.Go to exchange profile

    http://<IP>:<Port>/exchangeProfile/index.html

    Then RuntimeWorkbench -> com.sap.aii.rwb.server.centralmonitoring.r3.ashost = " Mention FQDN here "

    ->com.sap.aii.rwb.server.centralmonitoring..httpport = 8000

    2. Reinitialize the RWB service by : http://xiserver:50000/rwb/rtc?op=init

    3. RZ10 - Make an entry for /icm/host_name_full

    *************************************************8

    You should give fully qualified host name for the xi server (parameter, icm/host_name_full). Also set the same in exchange profile parameter com.sap.aii.rwb.server.centralmonitoring.r3.ashost.

    - Creating HTTP Destination pmistore in the Java Environment

    from XI installation guide (config in visual admin)

    - Check if services in transaction SICF for RWB - if they are activated

    - on your XI box go to TCODE - SE38 and run program - RSXMB_ACTIVATE_ICF_SERVICES.

    - check SAP note: 750287 (XI 3.0 Runtime Workbench: Alert configuration does not start) and change values in your ExchangeProfile.

    - check if you can accept cookies.

    It should work friend....!!!!

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 17, 2008 at 05:32 AM

    Hi,

    some ICF service must be inactive

    do this execute the report in sm38 SXMB_ACTIVATE_ICF_SERVICES

    and in rz10 in intance profile, modify the value of

    icm/server_port_0 for this value

    PROT=HTTP,PORT=80$$,TIMEOUT=30,PROCTIMEOUT=602

    also see this

    Alert Management

    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/e04141e8-0f11-2a10-adaa-9d97b062c2df

    RWB- Alert Configuration LInk isnot working

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 17, 2008 at 08:49 AM

    Thanks to everyone who has contributed in helping me resolve the Issue.

    My Issue is been solved when I had gone through the SAP Note 750287. I thank Arnab Mondal in this Regard in helping me.

    I had changed the Hostname and Port Parameters in the Exchange Profile and Updated the RWB Cache.

    Regards,

    Varun

    Add comment
    10|10000 characters needed characters exceeded