Skip to Content
avatar image
Former Member

Archiving & Deletion XI 3.0/ PI 7.1 - Need Help

Hi All,

I have configured the Archiving / Deletion settings in both Xi 3.0 & Pi 7.1. I had gone through the documentation from SAP Help & also the Step-by-Step Guides, Blogs, FAQs.

Brief Information abt my settings,

- Done the technical settings of the Archiving objects (Logical File name, Logical path.... etc)

- Done the Interface/ retention period settings etc..

I was able to do the archiving /deletion also, for many msgs. & also read them from Archive.

The main issue is, I am unable to archive/delete some msgs, which I expect to be Archived/deleted.

Cos these are exactly the interfaces I have given in the settings & these are well outside the retention period and they are successful Async msgs.

I could see them in SXMB_MONI (with similar input data as given in A/D settings).

When I run the Archiving job, it creates an empty run without archive file etc.

I am puzzled by the intermittent working of this set-up (I had been testing earlier and many msgs were archived), now I have narrowed down to couple of interfaces & trying to see the Archiving for them.

Is there any overall setting controlling this?? pls help.

Thanks

Knowledge Quest

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 15, 2008 at 06:28 PM

    Hi,

    Perhaps report RSXMB_SHOW_STATUS or RSXMB_SHOW_REORG_STAT will give you more

    information. Iu2019m wondering specifically about the Adapter Status at the bottom of the report RSXMB_SHOW_STATUS. You can directly take a look at the ADAPT_STAT values from table

    SXMSPMAST for the messages in question.

    If you see 001 or 008, then you will need to schedule report SXMS_REFRESH_ADAPTER_STATUS to run (SAP Note 872388). If you see 007, you may need to resolve the errors first.

    Thanks,

    -Russ

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 16, 2008 at 10:13 PM

    Dear Knowledge Quest,

    Russell is perfectly correct. The reports RSXMB_SHOW_STATUS and RSXMB_SHOW_REORG_STATUS he has mentioned provide an overview for all XML messages in XI persistency layer. The crucial point here is the fact that only a very limited number of status values allow archiving of messages.

    Also the OSS note 872388 mentioned by Russell is the right way to nail this down. This note lists most of the issues that prevent messages from archiving/deletion. Please walk through that note step by step to identify the root cause.

    In case you use the Business Process Engine (BPE) you might also want to have a look to OSS note 1042379 which describes reorganizational steps for BPE messages. As the inbound pipeline for BPE uses the XI persistency layer this interferes with archiving/deletion in XI.

    Best Regards,

    Harald Keimer

    XI Development Support

    SAP AG, Walldorf

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 18, 2009 at 01:30 PM

    Hi there,

    I have Achiveing for my XI system, I have changed the standard pfad for the archive in SARA -> Customising -> Pfad... I run the Archive job, and it makes a .ARCHIVE file in my folder, but then the archiving jobs gets aborted and the log view says: Fehler beim Zugriff auf die Archivdateien - Could not read the Achive files...

    Does anyone have an idea what is wrong? I cant eve see the archives in Statistics, or read them... In SXMB_MONI there are no archived messages, but in my folder are about 40 GB of ARCHIVE files...

    Thanks for advice...

    M

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 18, 2009 at 03:13 PM

    I have changed the ARCHIVE_GLOBAL_PATH to my data server. Do I need to change also the ARCHIVE_GLOBAL_PATH_WITH_ARCHIVE_LINK?

    thanks

    M

    Add comment
    10|10000 characters needed characters exceeded