Skip to Content

BPM : Message scheduled on the outbound side

Hi

I have messages in SXMB_MONI that have been received into my BPE. They have a status flag ok (chequered flag ) but the Outbound Status is green (message scheduled on outbound side).

The BPE would have finished by now ...been in Message Scheduled on Outbound side for the entire day now.

What has happened ? I have no error - nothing !

(there are no entries in SMQ2, nothing in SXMB_MONI_BPE in error etc etc or Short Dumps)

Please help.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Dec 15, 2008 at 12:56 PM

    Hi,

    did you try SMQ1 ? (outbound queue) ?

    Regards,

    michal Krawczyk

    http://mypigenie.com - XI/PI FAQ

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Jonny Wellard

      Hi Johnny

      From SXMB_MONI copy the message payload and test the mapping with the data in IR (Test Tab). Perhaps the mapping is not working for "this data" and if the first fails the subsequent messages will backup on the q. Most of the time I have seen this green flag on the outbound side it is related to the mapping in BPM.

      Thanks

      Damien

  • Posted on Dec 15, 2008 at 01:05 PM

    Hi,

    Try deleting Old instances in tcode SWWL.

    Thanks!

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 15, 2008 at 02:25 PM

    In addition to the below Clue, If you your QOS : EOIO and suppose your one message got strucked due to some error.There is a chance of struck for the subsquent messages,

    You need to find it out which message got struck up and clear that.Hope your problem resolve.

    Thanks

    Prabhakar

    Add a comment
    10|10000 characters needed characters exceeded

    • I posted an OSS note on this - so answer from SAP.

      Solution is to delete the old entries via RSWWWIDE report (which could also delete work items that do not have a final status.) I ran this for everything not COMPLETED.

      When I send another message in - it worked fine. So the fact I had a stalled WF a week ago was affecting any new one coming in.

      Drilling down into the message in SXMB_MONI from the PE I could see an Exception Handling in the MergeandSendBlock - no error given - but it did have a time of a week earlier.. anyway then in the ST22 Dump I could see wf-batch with runtime error MESSAGE_TYPE_X_TEXT.

      I feel this is very poor design on the BPM processing ! oh well.

      See also

      #Note 836092 - Archiving/deleting work items in the XI

      PS Thanks to Sudhir earlier on... You nailed it - but at that stage I did not know what you mean so did not consider this - as I had no idea what affect running that transaction would do.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.