Skip to Content
avatar image
Former Member

RNOTIFUPDATE01 termination with DNO_RFC_DATA BAdI ( Service Desk For Vars)

Hi Dear,

Looking for help to solve the problem I'm having on Solution Manager (Service Desk for Vars), to run the report RNOTIFUPDATE01 get the error message below;

But the customer RFCs have been generated, connects with the sap successfully. Business Add-In for RFC Connections with several SAP customer is active. This the Badi (AI_SDK_SP_RFC) is active.

But when you run the report I get the error below;

Error:

None of the installations were assigned to a destination in the BAdI

Message no. DNO190

Diagnosis

In your implementation of the BAdI DNO_RFC_DATA (method CHANGE_DESTINATION), a destination was not assigned to an installation. Due to this, no adjustment with the SAP problem notification system could take place.

Procedure

Check that you selected the correct installation numbers on the initial screen and in your implementation of the BAdI DNO_RFC_DATA, check the programming of the method CHANGE_DESTINATION for completeness and correctness.

AdI

thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Dec 13, 2008 at 02:15 AM

    Hi,

    The reason for this error is, that no RFC destinations to SAP OSS have been defined for the customer installations. Please refer to the IMG activites (transaction SPRO) within the folder:

    SAP Solution Manager->Configuration->Basic Settings->Standard Configuration of Basic Settings->Solution Manager->Connection to SAP->Multiple SAP Customer Numbers

    Cheers!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi, Thanks for your answer!

      But I had informed the previous message, the RFCs SM_SP_ <Cutomer Number> destination OSS for SAP customers have already been defined through IMG, the Badis are active and strangely when I run the program continues RNOTIFUPDATE01 the error.

      What may be happening?

  • Dec 16, 2008 at 12:59 PM

    Hi Antonio,

    plz check table AIINSTALLATIONS for entries. If there are missing entries there but you have entries in AISAPCUSTNOS check the job log of job REFRESH_ADMIN_DATA_FROM_SUPPORT for errors on these customer numbers. Doubleclick the messages! Check also FAQ note 1151450

    for helpful answers in this context.

    Regards

    Andreas

    Add comment
    10|10000 characters needed characters exceeded