Skip to Content
0
Former Member
Dec 11, 2008 at 03:42 PM

MAM reset problem after installing SAP MI 2.5 SP19 Patch 8

12 Views

Dear all,

I have just tried in a test system to upgrade at client side our MI 2.5 SP19 to patch level 8. At the moment we are using patch level 3 but there are some fixes that might solve some sync problems.

But when I do a MAM reset after the upgrade, I can not start up the Mobile Engine anymore. I'm using a dual core laptop and 50% (= 1 full core) of the processor is in use. After around 1 minute I get the following error message:

Time out 61
Can't Connect to server!

I had a look in the trace file and there I found the following:

[20081211 15:28:18:448] I [MI/API/Logging  ] ***** LOG / TRACE SWITCHED ON
[20081211 15:28:18:448] I [MI/API/Logging  ] ***** Mobile Infrastructure Version: MI 25 SP 19
                                                            Patch 08 Build 200710251458
[20081211 15:28:18:448] I [MI/API/Logging  ] ***** Current Timezone: Europe/Paris
[20081211 15:28:18:448] I [MI/API/Logging  ] ***** Current Trace Level: 50
[20081211 15:28:18:995] E [MI/Persistence  ] NESTED TRANSACTION ERROR: A transaction has
                                                             already been started

I 've tried to put the trace level a bit higher to see if I get more information, but when givin' in a higher trace level in the MobileEngine.config file (= 60 or higher), everything seems to work: I can reset the MAM and start the Mobile Engine up again.

MobileEngine.Trace.Level=1000

Has anyone experienced the same problem? After some tests, it seems that every trace level number below 60 lets the MI crash, while every number beginning from 60 or higher lets the MI start up as normal.

Does someone know what to do about it?

When rolling back to SP19 patch 3 it works again fine.

Thanks for your advice and feedback!

Best regards,

Diederik Van Wassenhove

Edited by: Diederik Van Wassenhove on Dec 11, 2008 4:43 PM