Skip to Content
Former Member
Dec 10, 2008 at 03:21 PM

Problem passing in parameters - (more complex then seems)


Ok passing parameters may look easy.. But there is more to it. I built 50 reports had all working with parameters. Then one day everything else runs fine in the project except for the parameters being passed to Crystal.. They still work in alot of places just not on my pc, when the project is on a specific server.

The deployed Intra-net works fine from my computer & everywhere else, even if I re-deploy it with the problem on my computer.

If I move the project to a different server the project works fine.

My co-worker can run the project on the server I am having problems with on her computer.

The error I get is :

Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=, Culture=neutral, PublicKeyToken= (numbers here..) failed.

Then it displays it's own prompts for Crystal.. And if I enter there the report runs. (my prompts are passed thru fields on my form. with the following command)

crSet.SetParameter("BeginDateRange", CDate(pbl.DateDflt(1)), "C")

I tried moving the forms & reports into a whole new Project. It did not work.

I thought it might be a strongname issue from reading. I created an Strong name with the sn.exe utility, and (I think) I got it attached to the program correctly... It did not help.

I tried uninstalling and reinstalling my VS.. I don't think much references where reset though as when I returned it still knew all the last projects I had opened.. And It did not work.

Help... Help.. Please..

Edited by: Wenda Stephens on Dec 10, 2008 4:24 PM