Skip to Content
avatar image
Former Member

BPM queue get block

Hi,

I have a web services that use bpm scenario. Every time when a error example date type format happen on the bpm the queue with get block on smq2 and others request by the web services will get hold. Any way that can i disable this? Every time i have to delete the error queue in order to let the webservices work again.

Thanks for help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Dec 10, 2008 at 08:05 AM

    You may increase the vlaue of the Tuning parameter in sxmb_adm -> Integration engine configuration -> specific configuration ->

    EO_OUTBOUND_PARALLEL

    EO_INBOUND_PARALLEL

    This will be of some help

    https://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/f0e73c7b-5301-2a10-f1ab-832f301b6c02

    Regards,

    Prateek

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 10, 2008 at 08:08 AM

    Hello,

    one more option is..select multiple queues in Integration process while defining the steps

    Regards,

    Sreenivas.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 10, 2008 at 09:04 AM

    Hi Fcgan,

    Use these reports to handle the queue in automated manner.

    · RSARFCSE: Restart an LUW (background job)

    · RSARFCEX: Restart tRFC LUWs (background job)

    · RSQOWKEX: Restart QOUT qRFC LUWs

    · RSQIWKEX: Restart QIN qRFC LUWs

    · RSARFCSE: Delete an LUW (background job)

    · RSARFCER: Delete various LUWs

    Thanks!

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 02, 2009 at 04:28 PM

    solve by catching the exception.

    Add comment
    10|10000 characters needed characters exceeded