Skip to Content
avatar image
Former Member

No switch to HTTPS occurred, so it is not secure to send a password

Dear Experts,

We are in the process of publishing our CRM Web UI url over internet for access. We were able to publish the same and access and login with HTTP, but at the login screen I am getting the warning message "No switch to HTTPS occurred, so it is not secure to send a password"

For this, I have set the parameters icm/server_port_1 with value PROT=HTTPS, PORT=443 and ms/server_port_1 with value PROT=HTTPS, PORT=443. Inaddition we have parameters icm/server_port_0 with value PROT=HTTP,PORT=80$$ and ms/server_port_0 with value PROT=HTTP,PORT=81$$

But still, I am not able to access the link through HTTPS, and able to login with HTTP. I have checked with the network admin and he said that URL is published for both http and https. Also, in SMICM I could see the services where HTTP is active, but HTTPS is not active and when I try to activate it it says operation failed.

Please suggest how can I overcome this issue

Regards,

Sharath

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Dec 09, 2008 at 12:22 PM

    hi,

    have you installed SAP cryptolib for SSL?

    -Gokul

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 09, 2008 at 11:58 PM

    Hello Sharath,

    Please refer to the following article at help.sap.com, which gives you instructions how to enable SSL for ABAP and JAVA:

    http://help.sap.com/saphelp_nw04s/helpdata/EN/13/4a3ad42ae78e4ca256861e078b4160/frameset.htm

    Regards

    Ventsi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 10, 2008 at 07:37 AM

    Hi,

    Thanks for your replies and no I have not installed anu SAP Cryptolib for SSL, is it mandatory to be installed for HTTPS access.

    Regards

    Sharath

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Of course it is mandatory to install the SAP Cryptolib to anable HTTPS on CRM.

      After enabling HTTPS, you have to configure the switch for HTTPS on the login page.

      This is done with transaction SICF on the alias node crm_logon

      Chosse the "Error Pages" tab, then "Logon Errors" sub-tab and click on the "System Logon" Configuration Button.

      Here, on the "Actions during Logon" frame, select "Logon via HTTPS".

      That's it !

      Regards,

      Olivier

  • avatar image
    Former Member
    Jun 12, 2009 at 07:24 AM

    Thanks

    Add comment
    10|10000 characters needed characters exceeded