Skip to Content
avatar image
Former Member

Visual Composer : numeric default value 0

Hi community,

this is the problem I am facing : I want to use a field with the default value 0 if the BAPI does not return a value.

But this particular 0 value is not taken, the BAPI that takes this parameters considers that the value of the field is NULL, so it does not work.

I tried with "0", 0, 000, a string field with "0" default values, but did not manage to find a good solution.

Does anyone got an idea ?

Thanks a lot.

Fabien.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Dec 09, 2008 at 03:52 PM

    No idea ?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 09, 2008 at 04:35 PM

    Hi,

    IF(ISNULL(vlaue),"0",value).

    Did you try with this condition?

    Regards,

    Murtuza

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 10, 2008 at 03:53 AM

    Hi,

    Are you giving the 0 (Zero) as Input to the Bapi.

    if yes what output you are Expecting From the BAPI after taking the Zero input ?

    Govindu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Murtuza I am using a table numeric field.

      Govindu, yes that is what I am giving to the BAPI. I expect that it use the 0 value, not the NULL value.

      By testing it with right click > test bapi in visual composer it works if I enter the 0 value, and gives me the error message I get in runtime if I enter no value.

      Thanks for your research.

      Fabien.

  • avatar image
    Former Member
    Dec 12, 2008 at 01:23 PM

    >

    > Hi community,

    >

    > this is the problem I am facing : I want to use a field with the default value 0 if the BAPI does not return a value.

    >

    > But this particular 0 value is not taken, the BAPI that takes this parameters considers that the value of the field is NULL, so it does not work.

    >

    > I tried with "0", 0, 000, a string field with "0" default values, but did not manage to find a good solution.

    >

    > Does anyone got an idea ?

    >

    >

    > Thanks a lot.

    >

    > Fabien.

    HI Fabien

    place a input field with data type number on the form (dont take data type text)

    and in this input field give the default value as 0(Zero)

    and in the same input field select formatting tab

    select numeric radio button , uncheck the local format and under decimal places drop down list select 0 (Zero) and under thousand separator select none

    this above will show 0 (zero ) in input field

    now map this input field as default value to the BAPI which your using

    hope this works

    Regards

    Srinivas

    Add comment
    10|10000 characters needed characters exceeded