Skip to Content
avatar image
Former Member

#ABAP_Trial

I am trying to install ABAP as 751 Sp02 on Linux. I am specifically stuck on step C number 13 of the following article, "https://blogs.sap.com/2017/09/04/newbies-guide-installing-abap-as-751-sp02-on-linux/".

Step 13 says to

Enter the root’s password and navigate to the shared folder with the ABAP installation: cd /media/sf_s4installer.

When I try to run the cd command, it tells me that the file or directory does not exist. I downloaded my abap rar files (10 total) and saved them locally to a shared folder named s4installer as mentioned in step 4.

I have completed the steps up to this point without error.

I tried to move on to step D which is Installing ABAP but the ./install.sh command gives the same error that no such file or directory exists.

Please help, thank you.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Mar 24 at 01:31 PM

    I have exactly the same problem, I think it´s related with the "Guest Additions" included in Virtual Box (are installed after Virtualbox from Devices-->Insert Guest additions CD Image).

    In my case I´ve installed it but this "additions" are not running ( I see in /opt/VBoxguestadditions-6.0.4 with command init/vboxadd-service status).

    Even If I try to do it manually (setting the shared folder) with :

    sudo mount -t vboxsf s4installer /media/sf_s4installer , I receive the message:

    "/sbin/mount/vboxsf :mounting failed with the error: No such device", which seems to be related with the "Guest Additions" too.

    My Vm is Suse Linux 42.3 , Virtual Box is 6.0 and I´m afraid that is a problem of versions .

    I.'ve been searching around and it seems to be a very common problem .

    Fortunately my NSP on Windows is still working .....

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 24 at 05:06 PM

    Update:

    The solution to make it work the Vbox guest additions (and after it,to be able to configure the shared folders) is in:

    https://en.opensuse.org/VirtualBox

    I´ve followed the steps under;

    "Installing the latest version of the guest additions"

    and now it seems I´ll be able to continue with the next step of installation (from the excellent blog "newbies-guide-installing-abap-as-751-sp02-on-linux" step D;Install Abap)

    Thanks

    Add comment
    10|10000 characters needed characters exceeded