Skip to Content
0

Connecting to SAP HANA Express edition from different computer

Nov 05, 2016 at 08:24 PM

679

avatar image
Former Member

Hello Experts,

I recently installed HANA express edition (server+apps) in SUSE linux using OVA image file. All the configuration is completed based on the installation document.

In the same computer, I have eclipse installed with HANA tools and able to connect successfully to the HANA system.

But, I would like to know, how to reach this HXE system from different computer.

Basically, I would like to leave the installation in one machine and would like to connect and work from different machine.

In the other machine, I tried the same steps of adding the system in HANA administration console, but it could not reach the machine were HANA is installed.

Any suggestions?

Regards,
Raghav

10 |10000 characters needed characters left characters exceeded

Is your VM in the same network than the system from which you wanna connect to the HXE system? Did you use a host name or an IP for the connection? What errors do you get?

2
Former Member
Florian Pfeffer

Hi Pfeffer,

Thanks for the response. Please find the details below.

Is your VM in the same network than the system from which you wanna connect to the HXE system?

Yes. Both the machines were in the same network. Although this question now bugs me to find if there are any restrictions if not from the same network.

Did you use a host name or an IP for the connection?

IP address found in the VM command /sbin/ifconfig along with instance # 00. The same IP address when I tried pinging in windows CMD prompt, like "PING XX.XX.XX.XX", I did get the response without any failures(not sure if this is relevant here). This issue happens only for Eclipse while trying to add the system.

What errors do you get?

"The system cannot be reached. The logon data could not be used. Do you want to add the system anyway?"


In VM network setting, I have bridged option chosen. Is this happening because of any firewall or anti-virus?

Appreciate your response. Thanks.


Regards,

Raghav


0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member
Jan 31, 2017 at 11:55 PM
1

Hello Anuj and Karthik:

This thread discusses potential causes and solutions for when you do not get an ipv4 address: https://archive.sap.com/discussions/thread/3961879.

Regards,

Carl

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Dec 07, 2016 at 10:29 PM
0

Did you figure it out yet? When I do /sbin/ifconfig I don't get an inet address . I get an inet6 address which looks like a mac address rather than IP address. I am using virtualbox and did server only installation.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Anuj,

I am facing the same issue. Only inet6 mac address is listed. No inet ip address is listed. Have you found a solution ?

Thanks,

Karthik

0